You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, June 24th 2015, 7:21am

is it possible to make 360 video live streaming?

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
<plugin name="video"        url.flash="plugins/videoplayer.swf"
        url.html5="plugins/videoplayer.js"
        videourl="http://27.112.2.66:1935/live/mystream/playlist.m3u8"
        posterurl="videoposter.jpg"
        pausedonstart="false"
        loop="false"
        volume="1.0"
        preferredformat=""
        buffertime="0.1"
        ignoremetadata="false"
        volume="1.0"
        onvideoready=""
        onvideoplay=""
        onvideopaused=""
        onvideocomplete=""
        />

<image hfov="360" vfov="180">
   <sphere url="plugin:video" />
</image>


"HTTP Live Streaming (.m3u, .m3u8) - iOS, Mac Safari only"



but only get a blackscreen

2

Friday, June 26th 2015, 7:20am

Hi,

due an iOS bug it's not possible to display video-panos loaded from other domains (note - even a different port is interpreted as different domain).

See here:
http://krpano.com/plugins/videoplayer/#h…nownbrowserbugs
http://krpano.com/ios/bugs/ios8-webgl-video-cors/
https://bugs.webkit.org/show_bug.cgi?id=135379

Best regards,
Klaus

3

Saturday, June 27th 2015, 9:44am

thanks for the reply´╝ü

4

Monday, September 21st 2015, 8:39pm

If you serve the krpano files and HLS stream from the same domain you can get past the "DOM exception 18" error.


I've tried an initial test doing this, successfully avoiding that error, but am unable to get the video to render. The audio track is playing when using Safari Desktop, and it seems to also be playing on Safari iOS 9.0/iPhone, though, of course there's no audio in that case, and the counter keeps flashing between 0:00 and the current time (using the interface from the 'videointerface' example).

Any clue why the video might not be showing up? Would this be another example of the texture bug (https://bugs.webkit.org/show_bug.cgi?id=133511) which they claim is solved? Is there maybe an optimal bitrate/video size that would work?

5

Tuesday, September 22nd 2015, 11:04am

While I had problems playing streaming videos on iPhone6 but not on iPads, since I updated to iOS9 now even iPad is not playing the videos at all.
It seams that this is an iOS problem: https://discussions.apple.com/thread/7216194