You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, January 26th 2016, 10:41am

Domain-limited viewer files (krpano Protect Tool)

Hallo,

Ich habe versucht, domain-limited Viewer Files zu erstellen, stosse dabei aber leider auf Probleme.

Ich habe mich an die Anleitung gehalten, d.h. die Lizenz in den krpano-Folder kopiert, habe natürlich auch die Domain korrekt eingegeben, habe die Viewer Files generiert und ersetzt (d.h. die alten gelöscht und die neuen umbenannt, sodass sich Anpassungen in der HTML-Datei erübrigen).

Lokal kann ich das Panorama problemlos öffnen. Auf meiner Website funktioniert es allerdings nicht. Ich verwende Wordpress mit dem Panopress Plugin, das eigentlich problemlos funktioniert, auch mit den unbehandelten, ursprünglichen Viewer Files. In der entsprechenden Light-Box von Panopress wird mit den neuen Viewer Files aber bloss ein Abbild meiner Website dargestellt, mit einer 404 Meldung. Es erscheint keine krpano-spezifische Fehlermeldung (insbesondere keine Lizenzfehlermeldung oder ähnliches).

Was mache ich wohl falsch? *cry*

Bloss im Sinne einer "Gegenprüfung" habe ich einen weiteren Satz der viewer files erstellt und dabei "Disable local / offline usage" gewählt. Das klappt, d.h. das Panorama öffnet lokal nicht (aber selbstverständlich leider weiterhin auch nicht auf meiner Website).

Vielen Dank für Tipps! *smile*

Tom

toosten

Intermediate

Posts: 461

Location: Berlin

Occupation: freier Software-Entwickler ( HTML, JS, PHP, JSP, Flash, AS3, C++, Java, krpano, ---)

  • Send private message

2

Tuesday, January 26th 2016, 12:08pm

404 HTML-Datei nicht gefunden - hat nix mit krpano zu tun

3

Tuesday, January 26th 2016, 2:23pm

Hallo Toosten,

Vielen Dank für den Hinweis. Was 404 bedeutet, war mir eigentlich schon klar, ich konnte aber trotz intensiver Suche keinen Fehler finden.

Aufgrund deines Tipps bin ich dem nun aber nochmals nachgegangen. Und siehe da, da fand sich doch tatsächlich ein kleiner Typo. *thumbsup* *squint*

Nun funktioniert's... *smile*

Tom