You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

301

Tuesday, March 8th 2016, 10:19pm

Thank you very much for the hard work!

You know how the newer cardboard now ditched the magnets and went with the conductive foil button? Is there a way to register the button press and do something in response, like let's say go to next pano?

302

Wednesday, March 9th 2016, 3:09am

Hi, Administrator,
When will the next version release? *smile*
Thank you!

303

Saturday, March 12th 2016, 8:18am

HotSpot Disappear Issue

Hi Guys

I am using the krpano v1,19 p3.

I realise my hotspots wil always disappear 1second later.

Then I added in this code (red) which was found in the krpano_vr.xml.

<hotspot name="next" style="prevnextbtn" url="buttons/Btn_Next.png" ath="-157.795" atv="50.473" onclick="tween(ty|alpha, 8000|0.0, 2.5, easeInQuint, removehotspot(next)); skin_nextscene_loop(+1);" onloaded="if(vr_start_done === true, removehotspot(start); start_vr(); , tween(alpha,1); );" />

It worked. But can anyone explain what this particular line of code mean? How come the hotspots in each scenes stopped disappearing after i used this code?

Thanks for ur understanding. *smile*

304

Sunday, March 13th 2016, 9:34am

krpano whith gear_vr not fluid ?

Hello,

I make virtual visits with Panotour last few months and I diffuse them in virtual reality helmets .
I show the result to my clients in an oculus rift connected to a PC with a large configuration and then everything is fluid.
I would have the same result with a gear vr .. Is it possible?
The
360 ° panoramas of the gear- vr their application gives me something
really fluid and really good, but when I look at one of my achievement
with Panotour on the web with the gear- vr is jerky and it makes sick 30
seconds . *wacko*
Do you have the same problem?

Thank,

Dan

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

305

Sunday, March 13th 2016, 3:53pm

How are you getting it to display on gear vr?
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

306

Sunday, March 13th 2016, 8:02pm

thanks sachagriffin

with the browser dedicated gear-vr ( gear-vr connected to USB ), with Firefox or chrome ( gear-vr not connected to USB )

Not fluid

Dan

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

307

Monday, March 14th 2016, 1:31am

I don't understand. You mean with Package Disabler Pro?
Yes, it wont be fluid since thats with the phones Gyro.
There's no solution yet for webvr+gearvr as far as I know.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

308

Monday, March 14th 2016, 11:27am

Incompatible Mobile VR Devices / Browsers

hi there.

I have some problems to use VR with different devices or browser.

I try to use the MobileVR with the attribute mobilevr_support = true.

According to description, all oder many devices should be able to simulate VR also without WebVR API.

to remain objectively, I test now on the official test scenario:

http://d8d913s460fub.cloudfront.net/krpa…x.html?v=119pr3

I test with different browsers and devices and had to find out, that the compatibility is not as described.

Example: so on a Motorola Moto X™ (2. Generation) with Chrome 49.0.2623.91 it doesnt work, but the same device with firefox 45.0 can change viewer to VR.

Is there a compatiblity list or should someone create a list of devices and browsers to find out an limit these errors!? Are there similar experiences like mine?

thanks

309

Monday, March 14th 2016, 2:21pm

lightbox over hotspot in vr-mode

Hi,
I successfully updated my tour to 1.19 and VR support. What I don't get working is opening a lightbox (with html-content) in vr-mode.
Is there any way to do it?
I use
something like
<style name="..".... distorted="true"
onclick="js(popup('info/fewo.php?id=',get(name)));"
/>
which works in non-vr-mode.

here's the tour http://kieler-foerde-360.de/Kieler_Foerde/tour.html

maybe, there is some different way to get it working?

310

Monday, March 14th 2016, 2:42pm

bug when loading new scene?

We have updated krpano from 1.18.5 to 1.19 and we have one issue: When loading a new scene ( krpano.call("loadscene(scene" + fileName + ", null, null, null);");), the previous image is now shown for a while before loading the new image and this is really causing some confusion in the navigation. You can check what I exactly say if you go to https://goo.gl/dG9UAq and try to navigate using the hotspots. It used to work fine with 1.18.5. Any ideas?

Umalo

Professional

Posts: 1,046

Location: Osijek, Croatia, EU

  • Send private message

311

Monday, March 14th 2016, 2:47pm

We have updated krpano from 1.18.5 to 1.19 and we have one issue: When loading a new scene ( krpano.call("loadscene(scene" + fileName + ", null, null, null);");), the previous image is now shown for a while before loading the new image and this is really causing some confusion in the navigation. You can check what I exactly say if you go to https://goo.gl/dG9UAq and try to navigate using the hotspots. It used to work fine with 1.18.5. Any ideas?

Setup blending options: e.g. loadscene(scene1, null, MERGE, BLEND(1));
http://krpano.com/docu/actions/#loadscene

312

Monday, March 14th 2016, 2:55pm

We have updated krpano from 1.18.5 to 1.19 and we have one issue: When loading a new scene ( krpano.call("loadscene(scene" + fileName + ", null, null, null);");), the previous image is now shown for a while before loading the new image and this is really causing some confusion in the navigation. You can check what I exactly say if you go to https://goo.gl/dG9UAq and try to navigate using the hotspots. It used to work fine with 1.18.5. Any ideas?

Setup blending options: e.g. loadscene(scene1, null, MERGE, BLEND(1));
http://krpano.com/docu/actions/#loadscene
I have the same issue in my tour although I use exactly the above mentioned blending options...

313

Monday, March 14th 2016, 4:25pm

The same here. Even using the load scene command: loadscene(scene1, null, MERGE, BLEND(1)); the old image still displays for a while.

314

Monday, March 14th 2016, 4:55pm


Setup blending options: e.g. loadscene(scene1, null, MERGE, BLEND(1));
http://krpano.com/docu/actions/#loadscene


Thanks for your fast reply, but using these settings doesn't make a difference.

315

Tuesday, March 15th 2016, 7:48am

Hi,
with Panotour on the web with the gear- vr is jerky and it makes sick 30
seconds
Native GearVR applications can use special GearVR hardware features like - the 'low persistence' screen refresh (no screen blurring during moving), time-warp (re-projection of the already rendered screen to match the latest available gyro data) and a higher quality gyro,

but a normal browser doesn't have access to these features - a browser can only do normal WebGL rendering and use the devicemotion events for the gyro tracking.

The only possibility how this could change is when Oculus/Samsung would provide access to these features - e.g. maybe via the 'WebVR API'. Then krpano could be theoretically automatically as good as native applications (like on Desktop where the WebVR is partially already available).

But please note here also that this is all in the beginning, there are no standards or reliable and stable APIs for VR yet anywhere. This will evolve with time.


Is there a compatiblity list or should someone create a list of devices and browsers to find out an limit these errors!? Are there similar experiences like mine?
Yes - see here the 'requirements' for mobile devices:
http://krpano.com/plugins/webvr/#mobilevr_notes

What I don't get working is opening a lightbox (with html-content) in vr-mode.
That's impossible for two reasons:
1. lightbox (=html content) doesn't do/support any stereo rendering
2. in real WebVR mode (OculusRift/HTC-Vice) only 'WebGL' content can be shown (in krpano currently only the pano and the hotspots are rendered by WebGL).

Best regards,
Klaus

316

Tuesday, March 15th 2016, 8:28am

Device list compatibilty and specifications : Homido

http://www.homido.com/en/how-to-use/compatibility


I have the LG G3 and it works perfectly !

317

Tuesday, March 15th 2016, 1:31pm

Hi,
with Panotour on the web with the gear- vr is jerky and it makes sick 30
seconds
Native GearVR applications can use special GearVR hardware features like - the 'low persistence' screen refresh (no screen blurring during moving), time-warp (re-projection of the already rendered screen to match the latest available gyro data) and a higher quality gyro,

but a normal browser doesn't have access to these features - a browser can only do normal WebGL rendering and use the devicemotion events for the gyro tracking.

The only possibility how this could change is when Oculus/Samsung would provide access to these features - e.g. maybe via the 'WebVR API'. Then krpano could be theoretically automatically as good as native applications (like on Desktop where the WebVR is partially already available).

But please note here also that this is all in the beginning, there are no standards or reliable and stable APIs for VR yet anywhere. This will evolve with time.


Merci *smile*

spacerywirtualne

Professional

Posts: 851

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

318

Tuesday, March 15th 2016, 2:07pm

Problem with "depth" hotspot parameter?

Hi

In the documentation is written that the parameter "depth" can be controlled "stereoscopic 3D depth of the hotspot". Brilliant idea and we wanted to use it.
krpano 1.19 - Pre Release 1 - WebVR / MobileVR / Stereoscopic 3D Support (Oculus Rift, Google Cardboard, GearVR, ...)
"To provide more possibilities here, krpano supports a new depth setting for hotspots to set the 'stereoscopic 3d depth' of the hotspot (default=1000)."

And here comes the problem.
Without adding "depth" in tour.xml hotspot in VR mode it seems to be "placed" a few meters away from the observer. The "depth" does not help in setting the "distance" of the hotspot from the observer. "Depth" behaves just like "scale". Does not control the shift of the hotspot for the left and right eye, but changes its scale.
For us it is a very serious matter. How to set the hotspot to "infinity" in VR mode (no shift pixels)?






Regards
Pawel
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

319

Tuesday, March 15th 2016, 3:38pm

How to set the hotspot to "infinity" in VR mode (no shift pixels)?
The next release supports - depth="off" - for this case.

spacerywirtualne

Professional

Posts: 851

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

320

Tuesday, March 15th 2016, 5:25pm

Thanks for answer, Klaus.

So... I can`t set the hotspot to "infinity". *sad*
I'm looking forward to the next release.

Best for you *thumbup*
Pawel
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*