You are not logged in.

1

Thursday, November 7th 2013, 12:31pm

BUG krpano 1.17 HTML5 Viewer | hotspot.zoom is ignored

Hello,


I'm working on a project that uses the 1.17 version successfully. With the last update from 2013-10-28, it appears a problem, which wasnt there in previous versions.

In the original flash version all is working fine.

The Problem is the "zoom" flag on a hotspot. In the last version the hotspots with zoom = true, changed the size of the image together with the pano when zooming. Now with the newest version, the scaling and the zoom-behavior differs from well functioning flash version.

I'm working on a flat multires Panorama with lots of image hotspots like:

Source code

1
2
<style 	name="country_hs" pixelhittest="false" alpha=".3" enabled="true" keep="true" align="center" scale="0.001472" zoom="true" onover="ifnot(activecountry == name, show_infotext(get(infotext)); set(alpha, .6); );" onout="ifnot(activecountry == name, reset_infofield(); set(alpha, .3); );" />
<hotspot name="map_" style="country_hs" url="sa.png" zorder="10" ath="0.035436" atv="0.01317" infotext="Projekte" onclick="activate_country(get(name)); lookto(0.04,0.01,0.07, smooth(.1,.2,.2)));"/>



It would be nice, if the bug could be fixed soon.

Thank you very much.

This post has been edited 1 times, last edit by "mjdevil" (Nov 7th 2013, 12:53pm)


2

Wednesday, March 23rd 2016, 2:36pm

I have a similar problem with the actual krpano Version 1.18.

Everything works fine until I set the zoom flag of a hotspot to true. The image of the hospot now spreads all over the panorama-field.
The problem is the same for the Flash- and HTML5-Viewer.

Here's the code of a hotspot I'm using:

Source code

1
<hotspot name="hs1" url="pic.png" zoom="true/false" ath="0.02" atv="0.05" />


Any advice is welcome.