You are not logged in.

progrock

Beginner

  • "progrock" started this thread

Posts: 4

Location: Berlin

  • Send private message

1

Friday, August 28th 2015, 10:39am

Fehlermeldung in Firefox 40.0.2 "HTML5 Browser with CSS3D or WebGL support required" bei Option html5:"only"

Ich verwende krpano auf meiner Homepage http://www.schlueter-fotodesign.de zur Präsentation von Panos und Slideshows. Leider werden die Slideshows bei manchen Firefox-Nutzern fehlerhaft wiedergegeben, obwohl Firefox in allen Fällen aktuell ist (40.0.2). Es stellte sich heraus, dass Firefox bei den Nutzern, die Fehler beobachteten, Flash nutzte, obwohl html5 auf "prefer" gesetzt war. Wenn html5 bei diesen Nutzern auf "only" gesetzt wird, erscheint die Fehlermeldung "HTML5 Browser with CSS3D or WebGL support required". Welche Ursachen könnten für dieses Verhalten mancher aktueller Firefox-Installationen in Frage kommen?

2

Monday, August 31st 2015, 11:42am

Hi,

die Meldung:

Source code

1
HTML5 Browser with CSS3D or WebGL support required


bedeutet der Browser bietet weder CSS3D noch WebGL Support - und damit auch keine effektive Möglichkeit Panoramen mittels HTML5 darstellen. (Bei html5=prefer wird in dem Fall dann automatisch Flash als Alternative verwendet).

Die Ursachen für nicht vorhandenen CSS3D/WebGL Support sind in den meisten Fällen zu alte Grafikkartentreiber oder viel zu alte Grafikhardware. Firefox kann (oder möchte) dann die Grafikhardware nicht zur Darstellung nutzen und ohne ist CSS3D oder WebGL nicht möglich.

Schöne Grüße,
Klaus

3

Thursday, September 10th 2015, 11:28am

Ich vermute mein Problem ist ähnlich. Um den kommenden Ärger mit windows 10 zu vermeiden bin ich auf Linux umgestiegen. Als Brauser verwende ich Firefox 40. Meine eigenen Panoramen kann ich nicht mehr anschauen. Es kommen immer Fehlermeldungen zu Adobe flash. In einer virtuellen Box habe ich noch windows installiert und verwende dort auch Firefox 40. Dort, also auf dem selben Rechner funktionieren die Panos. Die Panos von progrock kann ich unter Linux auch nicht sehen. Bei Linux bin ich Anfänger. Linux soll aber Adobe nicht mögen.

Hier eines meiner Panoramen:
Grotten

4

Monday, September 14th 2015, 10:57am

Meine Vermutung ist falsch. Ich habe Linux auf einem Notbuch installiert, und dort funktioniert die Anzeige von Panoramen. Man muss opengl verwenden.. Ich suche noch wie man das schafft.

5

Thursday, February 11th 2016, 6:16pm

Hab das Problem seit Firefox 44 jetzt auch. Zuletzt lief es noch - jetzt nicht mehr. Wieso das jetzt nicht mehr läuft finde ich seltsam. Grafiktreiber hat sich ja nicht geändert, erklärt also nicht wieso es jetzt nicht mehr geht. Auf der Seite taucht FF 44 nichtmal auf: https://wiki.mozilla.org/Blocklisting/Bl…raphics_Drivers

Werd den Treiber trotzdem updaten - liegt eh an. Wenn das hilft wäre ich froh, aber das kann ja auch ein generelles Problem sein. *unsure*

6

Friday, February 19th 2016, 7:38am

Es gibt in Firefox einen Sonderfall - falls der Browsers öfters wegen WebGL abgestützt ist (wegen fehlerhafter Grafiktreiber), dann merkt sich Firefox dies und blockiert/deaktiviert den WebGL Support daraufhin.

Eventuell ist das der Fall - suche einmal bei 'about:config' nach 'gfx.crash' zu setzte die Werte zurück.

Schöne Grüße,
Klaus

7

Tuesday, March 29th 2016, 10:35pm

FYI:
Hatte hier jetzt auch das Problem, FF 45 upgedatet und error Fehlermeldung...

Aktualisierung Treiber hat geholfen... ;-)