You are not logged in.

  • "Douglas Rhiner" started this thread

Posts: 98

Location: Fairfax, CA

Occupation: Code-Slave

  • Send private message

1

Thursday, January 28th 2016, 8:01pm

Video reverse seek - seek to time previous to the current paused time.

I'm trying to understand the sequence of events needed to seek to a time in a video that is previous to the current time and then getting the video to play, correctly.
The example below refers to one video that is loaded as per the "autoplay work around" exemplified on the 360 video example for mobile VR.

A video is loaded with a total time of 30.9057 seconds. L
everaging the video_auto_start action.

The video is played and immediately seek(ed) to 20.085 seconds.

The video continues to play and is paused at 30.8398 seconds, for a duration of approx->10.75 seconds.

The video is played and immediately seek(ed) to 9.27 seconds.

The video SHOULD continue to play and pause at 19.93 seconds. However, the video does not seem to play and pauses at 9.27 seconds, right where this call started.
Then if The video is played and immediately seek(ed) to 20.085 seconds, the video continues to play and is paused at 30.8398 seconds as expected.


Anyone have any idea why this is happening?
I've added in a pause and play after the seek and many other combinations of calls to try to mediate this.


Here is the code that is relevant to this issue.


<action name="gotrans">
loadscene(transscene, null, MERGE|KEEPVIEW|KEEPMOVING, BLEND(1));
set(hotspot.enabled,false);
set(autorotate.enabled,false);
plugin[trans].play();
plugin[trans].seek(%1);
set(trans_time,false);
asyncloop(trans_time == false, if(plugin[trans].time GE %2, set(trans_time,true));, plugin[trans].pause(); delayedcall(0.1, loadpano(mobile_scene_xml.php?sceneid=%3&amp;fromtrans=true, view.hlookat=%4&amp;view.vlookat=%5&amp;view.fov=100, MERGE, BLEND(3))); );
</action>

Tuur

Sage

Posts: 3,162

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

2

Tuesday, May 10th 2016, 3:43pm

Hi,
maybe try to 'roundval ' the video time.
Worked for me.

because
http://www.krpano.com/forum/wbb/index.ph…64996#post64996

hope it helps,
Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Similar threads