You are not logged in.

mc360photo

Trainee

  • "mc360photo" started this thread

Posts: 44

Location: ITALY

Occupation: Photographer

  • Send private message

1

Thursday, July 21st 2016, 5:30pm

Querystring parameters h and f are forced null

I have generated a simple 1 scene pano using MAKE PANO (MULTIRES) v 1.19-pr5

I have inserted an "onstart" action in generated XML to trace querystring parameters h,v, f (see below the xml generated).
I call the generated html page with h,v, f parametrs defiened as follows: http://192.168.2.2:8090/Scene0001.html?h=60&v=-30&f=90

The showlog() trace always null for h and f parameters, only v is properly traced. It seems that h and f are someway filtered!!
This is a big issue because h, v, f, in querystring are used by Kolor PanotourPro as deeplink parameters and i can't change the names

Please is a bug or I am doing something wrong??


<krpano>
<action name="myOnStart" autorun="onstart">
showlog();
trace(get(h));
trace(get(v));
trace(get(f));
</action>

<!-- the skin -->
<include url="skin/defaultskin.xml" />

<!-- view settings -->
<view hlookat="0" vlookat="0" maxpixelzoom="1.0" fovmax="150" limitview="auto" />


<preview url="Scene0001.tiles/preview.jpg" />

<image type="CUBE" multires="true" tilesize="512">
<level tiledimagewidth="2304" tiledimageheight="2304">
<cube url="Scene0001.tiles/mres_%s/l3/%v/l3_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="1152" tiledimageheight="1152">
<cube url="Scene0001.tiles/mres_%s/l2/%v/l2_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="640" tiledimageheight="640">
<cube url="Scene0001.tiles/mres_%s/l1/%v/l1_%s_%v_%h.jpg" />
</level>

<mobile>
<cube url="Scene0001.tiles/mobile_%s.jpg" />
</mobile>
</image>

</krpano>

2

Monday, July 25th 2016, 10:31pm

Hi,

I have tested your case and it's working fine.

Are you sure that you don't have any other code in your example that uses these variable names?
And why can't you change the names, your example code doesn't look like one from Panotour?...

Best regards,
Klaus

mc360photo

Trainee

  • "mc360photo" started this thread

Posts: 44

Location: ITALY

Occupation: Photographer

  • Send private message

3

Sunday, August 7th 2016, 11:13am

Sorry Klaus but it is not working for me!!

I am sure no other code is inserted in what is generated by dropping a tif file on "MAKE PANO (MULTIRES) v 1.19-pr5" tool except for the action "myOnStart" that is only tracing querystring parameters.

I have also tested with a just downloaded 1.19-pr6 version of krpano to be sure nothing changed from your delivered sw and result is the same, h and f are not passed!!

I have also tested with other single letter querystring parameters and all the alphabet is passed properly to krpano code except f,h,m,w !!!

You are right that the example code doesn't look like one from Panotour but because deeplink was not working for me with Panotour generated code, I started to check if the issue was with krpano to avoid complexity of Panotour testing.
I will post the problem also on Panotour forum.

Thanks
Marco

4

Monday, August 8th 2016, 1:01pm

Hi,

sorry, you were right - there was a bug here (in the embedding script) - some parameters weren't passed (they were wrongly detected as something else).

I have just uploaded a new and fixed version (1.19-pr6 build 2016-08-08 - no change in the version number this time, only the build date had changed).

Best regards,
Klaus

mc360photo

Trainee

  • "mc360photo" started this thread

Posts: 44

Location: ITALY

Occupation: Photographer

  • Send private message

5

Monday, August 8th 2016, 1:51pm

Thanks Klaus