You are not logged in.

Dear visitor, welcome to Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Thursday, September 15th 2016, 11:38am

VR video is opening in iOS 10 native video player

Dear Klaus,

I'm having an ios/android 360 video solution running on a hybrid app's inAppBrowser. Till iOS 10 everything was fine, but as you know on iOS 10 the app was crashing.
I installed the pr7 release which runs on iOS9 and Android, but on iOS 10 the video is also opened by the native 2d video player, though I can notice that is still running in the webview too.
I made some digging and I came to the conclusion the the issue is coming from the new videoplayer.js file from pr7, since if I'm replacing it with pr6 it is working, except that has a huge lagging on iOS 10.

Could you suggest something which I could try out to block the native video player?

EDIT: I also tried the demo page from your website to open in inAppBrowser (just to eliminate eventual implementation issues), with the latest videoplayer.js it's opening in the default phone player, with pr6 version is fine.

Thanks you!

This post has been edited 2 times, last edit by "stephnx" (Sep 15th 2016, 1:08pm)


Thursday, September 15th 2016, 1:59pm


see here:
krpano 1.19-pr7 with iOS 10 support

Try to enable inline-video-support in your app browser - e.g. like here:…bcfb2%5E%21/#F0

Best regards,


Thursday, September 15th 2016, 5:29pm

Dear Klaus,
Thank you very much for the help you are providing!
I also taking the chance to thank you for the hard work you investing into krpano to make it as suitable as possible for us!

For others who might read this post, based on the solution provided by Klaus, I changed manually inside Cordova InappBrowser iOS source CDVInAppBrowser.m file the line into: self.allowinlinemediaplayback = YES; (since the <preference name="AllowInlineMediaPlayback" value="true" /> in config.xml is completely ignored) everything works as intended!

Thank you again!

Best Regards,