You are not logged in.

1

Monday, October 3rd 2016, 3:49pm

[Solved] RTMP (wowza) streaming issue in panoramic mode

Hi,

I can't figure out why RTMP streams from wowza server play only audio in panoramas (image still black) but the server send a well configured crossdomain.xml.
I always have this error :
SecurityError: Error #2123: Security sandbox violation: BitmapData.draw

RTMP stream URL
rtmp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov

Crossdomain file
http://wowzaec2demo.streamlock.net/crossdomain.xml

krpano.xml
Works in flat mode

<krpano>
<security cors="">
<crossdomainxml url="http://wowzaec2demo.streamlock.net/crossdomain.xml" />
</security>
<plugin name="video"

url.flash="/plugins/videoplayer.swf"
url.html5="/plugins/videoplayer.js"
pausedonstart="false"
loop="false"
videourl="rtmp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov"/>
</krpano>


Doesn't work in pano mode

<krpano>
<security cors="">
<crossdomainxml url="http://wowzaec2demo.streamlock.net/crossdomain.xml" />
</security>
<plugin name="video"

url.flash="/plugins/videoplayer.swf"
url.html5="/plugins/videoplayer.js"
pausedonstart="false"
loop="false"
videourl="rtmp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov"/>
<image>
<sphere url="plugin:video" />
</image>
</krpano>

Do you have any ideas about the issue?

Thanks and regards

This post has been edited 1 times, last edit by "paulbottein" (Oct 5th 2016, 10:48am) with the following reason: Problem Solved


2

Wednesday, October 5th 2016, 10:51am

My problem is solved.

I modified the application.xml on the Wowza Streaming Server by adding this line :

<StreamVideoSampleAccess>*</StreamVideoSampleAccess>