You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, December 1st 2016, 8:46am

HTML5 in Chrome Keine Darstellung der Bilder ?

Hallo
ich bemerke plötzlich das die Panoramen die ich mit Krpano veröffentlicht habe im Chrome (Version 54.0.2840.98 (64-bit)) nicht mehr laufen (fast weisse Seite) z.Bsp. http://tavola-grande.de/vtour/ das ist aber nicht nur bei meinen so wie ich festgestellt habe. z.Bsp: http://360.schnurstracks.de/panoramafoto…ke-rhein-5.html läuft auch nicht habe es auch mit Chrome Canary versucht ohne erfolg außerdem habe ich die Tour mit Krpano Tool ubgedatet.


was kann ich tun?


LG Jörg

2

Thursday, December 1st 2016, 11:28am

I have the same problem, I think. I don't speak German but the link explain the problem. I've the same situation here:
http://www.lucca360.it/

http://www.lucca360.it/panoramiche/lago-…saciuccoli.html

Both the link above with 1.19 pr8

http://www.thinklab360.com/firenze-virtu…giovanni01.html

http://www.thinklab360.com/firenze-virtu…o/facciata.html

Both the link above with 1.19 pr4

All works good in safari and firefox - Mac Os 10.11.5

Thanks,
Leonardo

First post after years of use of KrPano *smile*

3

Sunday, December 4th 2016, 8:49pm

Hi,

sorry, aber ich kann kein Problem erkennen oder nachvollziehen.

Steht irgendetwas in der Chrome Konsole?
(mittels Menu->Entwicklertools oder per Strg+Shift+I oder F12 zu öffnen)

Und was bei:

Source code

1
chrome://gpu


Schöne Grüße,
Klaus

4

Monday, December 5th 2016, 8:40am

Console

VM1060:1 The devicemotion event is deprecated on insecure origins, and support will be removed in the future. You should consider switching your application to a secure origin, such as HTTPS. See https://goo.gl/rStTGz for more details.
Ri @ VM1060:1
Mr.registerplugin @ VM1060:2
(anonymous) @ VM1015:1
(anonymous) @ VM1015:1
h.onreadystatechange @ VM1015:1


das ist nur eine Warnung...

und das ist bei allen Seiten von krpanno so auch http://krpano.com/tours/paris/ die mit (sorry) Pano 2vr erstellten laufen einwandfrei...

Ich kann nirgends den Eintrag chrome://gpu finden...


LG Jörg
cryptoxyz has attached the following images:
  • chrome.jpg
  • firefox.jpg

toosten

Intermediate

Posts: 465

Location: Berlin

Occupation: freier Software-Entwickler ( HTML, JS, PHP, JSP, Flash, AS3, C++, Java, krpano, ---)

  • Send private message

5

Monday, December 5th 2016, 12:04pm


Ich kann nirgends den Eintrag chrome://gpu finden...
LG Jörg


Das soll in die Adresszeile vom Chrome, wo sonst der Link reinkommt.

This post has been edited 1 times, last edit by "toosten" (Dec 5th 2016, 12:21pm)


6

Monday, December 12th 2016, 11:20am

chrome://gpu/

Graphics Feature Status
  • Canvas: Hardware accelerated
  • Flash: Hardware accelerated
  • Flash Stage3D: Hardware accelerated
  • Flash Stage3D Baseline profile: Hardware accelerated
  • Compositing: Hardware accelerated
  • Multiple Raster Threads: Enabled
  • Native GpuMemoryBuffers: Hardware accelerated
  • Rasterization: Software only, hardware acceleration unavailable
  • Video Decode: Hardware accelerated
  • Video Encode: Hardware accelerated
  • VPx Video Decode: Hardware accelerated
  • WebGL: Hardware accelerated

Driver Bug Workarounds
  • disable_framebuffer_cmaa
  • disable_multimonitor_multisampling
  • get_frag_data_info_bug
  • pack_parameters_workaround_with_pack_buffer
  • regenerate_struct_names
  • scalarize_vec_and_mat_constructor_args
  • set_zero_level_before_generating_mipmap
  • unfold_short_circuit_as_ternary_operation
  • unpack_alignment_workaround_with_unpack_buffer
  • use_intermediary_for_copy_texture_image
  • use_shadowed_tex_level_params

Problems Detected

Version Information


Data exported12.12.2016, 11:18:25Chrome versionChrome/55.0.2883.87Operating systemMac OS X 10.12.1Software rendering list version11.17Driver bug list version9.15ANGLE commit id4d208abb19262D graphics backendSkia/55 d1740f81c843c65acd58d1b571ce94b90fee99d0Command Line ArgsChrome.app/Contents/MacOS/Google Chrome -psn_0_53261 --restore-last-session --flag-switches-begin --flag-switches-end

Driver Information


Initialization time247In-process GPUfalseSandboxedtrueGPU0VENDOR = 0x1002, DEVICE= 0x6740 *ACTIVE*OptimusfalseAMD switchablefalseDriver vendorDriver version1.46.22Driver datePixel shader version4.10Vertex shader version4.10Max. MSAA samples8Machine model nameiMacMachine model version12.2GL_VENDORATI Technologies Inc.GL_RENDERERAMD Radeon HD 6770M OpenGL EngineGL_VERSION4.1 ATI-1.46.22GL_EXTENSIONSGL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrierDisabled ExtensionsWindow system binding vendorWindow system binding versionWindow system binding extensionsDirect renderingYesReset notification strategy0x0000GPU process crash count0

Compositor Information


Tile Update ModeZero-copyPartial RasterEnabled

GpuMemoryBuffers Status


ATCSoftware onlyATCIASoftware onlyDXT1Software onlyDXT5Software onlyETC1Software onlyR_8GPU_READ_CPU_READ_WRITE, GPU_READ_CPU_READ_WRITE_PERSISTENTRG_88Software onlyBGR_565Software onlyRGBA_4444Software onlyRGBX_8888Software onlyRGBA_8888GPU_READ, SCANOUTBGRX_8888GPU_READ, SCANOUTBGRA_8888GPU_READ, SCANOUT, GPU_READ_CPU_READ_WRITE, GPU_READ_CPU_READ_WRITE_PERSISTENTYVU_420Software onlyYUV_420_BIPLANARGPU_READ_CPU_READ_WRITE, GPU_READ_CPU_READ_WRITE_PERSISTENTUYVY_422GPU_READ_CPU_READ_WRITE, GPU_READ_CPU_READ_WRITE_PERSISTENT

benji33

Intermediate

Posts: 244

Location: France

Occupation: Senior Software engineer

  • Send private message

7

Monday, December 19th 2016, 1:29pm

Try to change the WebGL hardware acceleration.

1. Try chrome://settings and click on "Show advanced settings". In the system section, try to uncheck (or check if unchecked) the "Use hardware acceleration when available". Then relaunch Chrome and test it.

2. Try chrome://flags and activate "Override software rendering list" setting. Then relaunch Chrome and test it.

8

Friday, December 30th 2016, 10:02am

Hi,

sorry, aber das klingt nach einem Chrome WebGL Bug, vermutlich in Verbindung mit den OSX GPU-Treiber.

Funktionieren andere WebGL Webseiten?

Grundsätzlich lässt sich in einem solchen Fall aber von krpano Seite aus nicht wirklich etwas machen.

Probiere aber einmal Chrome Canary - das ist die aktuelle Chrome Version, eventuell hat Google diesen Bug bereits behoben:
https://www.google.de/chrome/browser/canary.html

und das ist bei allen Seiten von krpanno so auch http://krpano.com/tours/paris/ die mit (sorry) Pano 2vr erstellten laufen einwandfrei...
Läuft Pano2VR in dem Fall auch mit WebGL? (und nicht mit CSS3D oder Flash?)
Falls ja, dann wäre das natürlich seltsam.

Schöne Grüße,
Klaus