You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

tsukada

Beginner

  • "tsukada" started this thread

Posts: 27

Location: Tokyo, Japan

Occupation: Programmer

  • Send private message

1

Tuesday, December 6th 2016, 8:42am

Cookie and Authorization headers called from xml

Hi,

Depending on browsers, no Cookie header or Authorization header are sent to server, when urls are called from xml.
Those urls are for fetching another xmls, images, movies and so on. The result is the server responding 401 error.
Especially ie or edge doesn't send those headers at all.

This is so annoying when the page is placed on a restricted area.
When I use application server, I added ;jsessionid=xxx to urls for workaround but in case of basic auth, we have to add Authorization header, that cannot be done by just manipulating url attribute of xml. *wacko*

Is there any way to solve or, Klaus, could you be kind enough to implement?


tsukada

Beginner

  • "tsukada" started this thread

Posts: 27

Location: Tokyo, Japan

Occupation: Programmer

  • Send private message

2

Tuesday, December 6th 2016, 9:27am

As for basic auth, I found using
<security cors="use-credentials" />

solved the problem.

Similar threads