You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

floz

Trainee

Posts: 109

Location: Uppsala, Sweden

  • Send private message

21

Saturday, May 6th 2017, 5:28pm

copyswf

Thanks for your hard work, Klaus!

Just wondering, will

Source code

1
copyswf
make a return in the .config files ? I'm creating panos batch-wise and don't need the .swf file to be created each time...


Thanks!

panomaster

Intermediate

Posts: 272

Location: Kobyłka, Poland

Occupation: Virtual Tours - Spherical Panoramas - Krpano developer

  • Send private message

22

Saturday, May 6th 2017, 10:37pm

There is a problem with aligning text when it is used as hotspot (no matter - distorted or not). Piotr reported misaligning but there are others problem eg. in Chrome vcenter works well but in Firefox text itself is aligned to the bottom an it is cutted.

Look at the example http://ai360.pl/projekty/vr_menu/index4.html

23

Sunday, May 7th 2017, 10:00am

Hi,

Quoted

Still no way to use parent for hotspots in webvr mode ?
No yet, that's a way more complicated case because everything that has been done automatically by the browser (because all was html/css) has to be redone again manually for WebGL. I mean the layouting and the rendering of all involved elements. The first step here was the new textfield support and the next step will be a new internal layouting engine that will be designed for these requirements.

That's already planed and also already partially in work (several internals will be prepared step by step for that), but as this is a more comprehensive part, it will be probably not ready for version 1.19.

But by using several stacked hotspots (same ath/atv, offsets via ox/oy, ordered by zorder) it should be already possible to achieve almost the same.



Quoted

Just wondering, will copyswf make a return in the .config files ? I'm creating panos batch-wise and don't need the .swf file to be created each time...
Just set flash=false in the config files.

Or do you mean not creating any swf or js files?
For this case additionally the html setting (note - 'html' not 'html5') could be set to false in the config files.
Then only the images and the xml file will be created.



Quoted

But the text is not displayed in the center but on the left site.

Quoted

There is a problem with aligning text when it is used as hotspot (no matter - distorted or not). Piotr reported misaligning but there are others problem eg. in Chrome vcenter works well but in Firefox text itself is aligned to the bottom an it is cutted.
Thanks for reporting!
Sorry, I'm not sure how I could have missed such simple not working cases... *wacko*
There will be an update next week where these layout problems will be fixed.

Best regards,
Klaus

jeromebg

Professional

Posts: 729

Location: Angers - France

Occupation: Photographer

  • Send private message

24

Sunday, May 7th 2017, 10:43am

That's already planed and also already partially in work (several internals will be prepared step by step for that), but as this is a more comprehensive part, it will be probably not ready for version 1.19.

But by using several stacked hotspots (same ath/atv, offsets via ox/oy, ordered by zorder) it should be already possible to achieve almost the same.


Ok, I understand, thnax Klaus !

One more thing, is it possible not to cut text when using textfield as a hotspot and setting a width & height ?
It seems text won't go to the next line, I guess because it's transformed into bitmap ?
Is it a bug ?

Umalo

Professional

Posts: 1,046

Location: Osijek, Croatia, EU

  • Send private message

25

Sunday, May 7th 2017, 3:41pm

Great update. Thanks Klaus *thumbup*

mstoss

Intermediate

Posts: 280

Location: Berlin

  • Send private message

26

Sunday, May 7th 2017, 11:38pm

Good news! Thanks a lot :-)

Michael

27

Tuesday, May 9th 2017, 5:41am

Hello,thanks for your hard work
But I think the date in the release note are not correct *tongue* ,in the news section of the mainpage

This post has been edited 1 times, last edit by "relationcg" (May 9th 2017, 8:46am)


jschrader

Intermediate

Posts: 237

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

28

Tuesday, May 9th 2017, 12:50pm

Stereo, baby!
Finally. Thanks a lot and please move on ;-)

jschrader

Intermediate

Posts: 237

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

29

Tuesday, May 9th 2017, 2:00pm

Equirectangular stereo pairs like name_l.jpg and name_r.jpg do no create stereo tiles when dragged onto the batch files.
It works with over/under and cubestrips. What am I doing wrong?

I still cannot use the tour edior. It generates an error message that flash is required. Also when dropped on the testing server. Why?
(Using Chrome).

spacerywirtualne

Professional

Posts: 860

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

30

Tuesday, May 9th 2017, 2:32pm

I still cannot use the tour edior. It generates an error message that flash is required. Also when dropped on the testing server. Why?
(Using Chrome).
I checked and all my old online virtual tours build in the Flash Player stopped working on Google Chrome *huh* I think this is the end of Flash Player on this browser.

best regards
Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

jschrader

Intermediate

Posts: 237

Location: Bavaria, Germany

Occupation: Photographer, Producer

  • Send private message

31

Tuesday, May 9th 2017, 8:50pm

Oh. my bad. I read that wrong and thought it was fixed already. That explains it fo course <facepalm>:

"Bigger news (e.g. a Flashplayer-free tour-editor) and many other features are still in work ..."

32

Wednesday, May 10th 2017, 7:44am

Hi,
One more thing, is it possible not to cut text when using textfield as a hotspot and setting a width & height ?
That would be possible by disabling the wordwrap setting;
https://krpano.com/plugins/textfield/#wordwrap


But I think the date in the release note are not correct *tongue* ,in the news section of the mainpage
Thanks for notice! ;-)
Is corrected now.

33

Wednesday, May 10th 2017, 7:46am

Equirectangular stereo pairs like name_l.jpg and name_r.jpg do no create stereo tiles when dragged onto the batch files.
It works with over/under and cubestrips. What am I doing wrong?
Hmm... that should definitively work, just tested successfully again... *confused*

What are the full filenames and filepaths in your case?

Best regards,
Klaus

34

Wednesday, May 10th 2017, 8:13am

고맙습니다. 클라우스는 최고 ~

35

Wednesday, May 10th 2017, 3:37pm

That would be possible by disabling the wordwrap setting;
https://krpano.com/plugins/textfield/#wordwrap

when renderer is webgl wordwrap can not work

Source code

1
2
3
set(hotspot[get(tooltipname)].wordwrap,true);
set(hotspot[get(tooltipname)].width,200);
set(hotspot[get(tooltipname)].height,200);

text="when renderer is webgl。wordwrap can not work"

36

Wednesday, May 10th 2017, 6:11pm

hm i just noticed,

that if you use google chrome 58.0.3029.110 on macosx 10.10.5 the screen stays blank white...
to be precise : the toolbar shows and works, but the panorama itself stays white, nothing visible

the console shows no errors, but if i set it to verbose i can see
"[Violation] 'requestAnimationFrame' handler took 70ms"

this does not happen on sierra with the same google version
also no problems with safari and firefox neither on 10.10.5 nor on sierra.

.... ?

37

Wednesday, May 10th 2017, 8:44pm

when renderer is webgl wordwrap can not work
That's also related to the layout problems mentioned a few posts above.
There will be a new krpano release in the next hours where this will be fixed.

38

Wednesday, May 10th 2017, 8:47pm

that if you use google chrome 58.0.3029.110 on macosx 10.10.5 the screen stays blank white...
Sorry, but that sounds like a GPU/GPU-driver related problem of Chrome.
That should be not krpano related.
Are other WebGL pages working on that system with Chrome?

39

Wednesday, May 10th 2017, 11:02pm

Hi,

there is a minor update from version 1.19-pr9 to version 1.19-pr10:

This release fixes several layout and rendering problems of the new textfield hotspot WebGL support.

Best regards,
Klaus

40

Thursday, May 11th 2017, 4:47am

Linux Tools

Hi! thank you for great update.

I downloaded linux version and extracted files, the tools are changed to js implement.
Is there still command line interface of linux tools? ( depend on node.js ?)

Please tell me how to use linux tools.