You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

spacerywirtualne

Professional

  • "spacerywirtualne" started this thread

Posts: 873

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

121

Monday, December 5th 2016, 11:27am

Hi
ERROR: html5soundunload - TypeError: Cannot read property 'unload' of undefined
Html5SoundUnload(name);

This error will occur if the parameter name insert the name of non-existent.

explanation

playHtml5sound2D(keep, soundname, audiofile, rate*, volume*,loops*, onload*, onplay*,onpause*,onstop*,onmute*, oncomplete*);
and
Html5SoundUnload(soundname);

soundname == soundname -> OK

soundname != soundname -> ERROR: html5soundunload - TypeError: Cannot read property 'unload' of undefined

best regards,
Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

122

Monday, January 2nd 2017, 9:33pm

html5soundunload - TypeError (...)

Hi there!

I just began to play around with the plugin and I must say it is amazing. I am doing a personal test art project, based on equirectangular images rendered in 3d, and I have the same problem (html5soundunload). But I have some extra notes to eventually help the "debugging" (mine... of course)

1) please note that the error only happens when I use the "Background sound". That is, when a scene with "3D" sounds only is loaded this message does not show-up. So if I began a tour with, say, two scenes, if the first only has "ambient" 3D type, it works without problems, but when one goes to other scene of the tour if the selected/loaded scene has "bckground sound" the message shows-up.

2) Different browsers give back "different" errors:

a) Safari
html5soundunload - TypeError: undefined is not an object (evaluating 'window[soundName].unload')

b) Firefox
ERROR: html5soundunload - TypeError: window[soundName] is undefined

Please note that I tried some different approaches, between putting code in sounds.xml or tour.xml (<action name = "...">), but I could not figure it out. If they could give some clues / quick examples on how to implement it was much appreciated.

Thanks for your attention and fantastic work.

Horácio Tomé Marques


A short note to contextualize myself: I, with two friends (ifuturo), have (one of) the most interesting history of 360/panorama project implementations in Portugal. Started early in 1996 we did some pretty amazing virtual tours, namely to our National Parliament. This particular project was done in 2002/2003 and still is online. At that time we did it in QTVR and some additional java and flash, so it still needs this "plugins" to work, but it works... fantastic no? We have much more, but, of course this theme is beyond the scope of this message.

http://www.parlamento.pt/VisitaParlament…as/default.aspx
http://app.parlamento.pt/visita/visita_virtual/

spacerywirtualne

Professional

  • "spacerywirtualne" started this thread

Posts: 873

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

123

Monday, January 2nd 2017, 11:22pm

Hello

Typically, this type occur if the user does not apply to the documentation. Sometimes it is a bug installation, missing line of code or a link to a file that does not exist, wrong file names, and so on... The causes can be many. That is, 95% of cases.
Does not change the fact that every time I help solve the problem. If errors occur I immediately fix them, but without a link to the project or a ZIP file, unfortunately, I can not help you.
Send me some link or ZIP file by Wetransfer.


Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

124

Tuesday, January 3rd 2017, 10:55am

html5soundunload (TypeError): documentation

Hi!

Dear Piotr,

you are absolutely right. Although I have some experience in interactive panoramic project development I am a real rookie in what it concerns languages such as js. Sorry to have sent you a message without first learning more about all this.

I will proceed now to a deep reading of the documentation. I will return to you only if I am not really able to solve other eventual issues!

Thanks again for your great work.

Sincerely,

Horácio

spacerywirtualne

Professional

  • "spacerywirtualne" started this thread

Posts: 873

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

125

Tuesday, January 3rd 2017, 1:07pm

Hi Horácio

I'm working on the next version of the plugin. Will be many improvements, better productivity and refactoring the main code *thumbup*

If you find some error please report it to me immediately.


Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

spacerywirtualne

Professional

  • "spacerywirtualne" started this thread

Posts: 873

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

126

Tuesday, January 3rd 2017, 3:48pm

Hi

The latest version of the HTML5-VR Audio Plugin ver 2.0 beta5 plugin is ready. The download link is sent to our clients.

Thanks for all your comments and suggestions. Thanks to you we can improve plugin to work better and better.


Piotr

p.s. If you not receive any email with download link - write to PM
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

127

Friday, January 20th 2017, 7:12pm

I've noticed an odd thing lately running the latest HTML5-VR and iOS 10.2:

There are times when I start a pano and the sound comes through on the iPhone speaker. I plug in my earbuds or headphones and the sound is still there. However, when I go back later and start fire up my pano in Safari, there's no sound. If I plug-in my earbuds at that point the sound is usually there. When I unplug, sometimes sound comes out of the device speakers and other times there's still no sound.

Killing safari seems to fix the issue, but sometimes it doesn't. Restarting the iPhone always fixes the issue for the first use, but after that the problem sometimes appears again.

It's been almost impossible to replicate this issue on a consistent basis, but the issue definitely exists.

Tnx!

128

Tuesday, January 24th 2017, 1:27am

HTML5 plugin sounds not working properly on Ipads both Ipad 2 and Ipad mini

Having a similar problem to landrvr1

Sound is working on iphone 6 plus on iOS 10.2

but on both ipad 2 - iOS 9.3.5

and Ipad mini - iOs 10.2

It only works with headphones plugged in it doesn't work with the speakers.

This was working before Christmas as I tested on both devices. Is there some sort of call to an external server or script in the encrypted plugin that has been updated or changed?

The ipad mini has had an iOS update in late December just after iOS 10.2 came out but the ipad 2 did not and will not but still exhibits the same problem. Again though unless an external script is being called it doesn't really make sense. Got a couple of big projects that are currently using this plugin and it's less than ideal to say the least that users on ipads can't listen to audio without headphones. :(

spacerywirtualne

Professional

  • "spacerywirtualne" started this thread

Posts: 873

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

129

Tuesday, January 24th 2017, 2:27pm

Hello
Having a similar problem to landrvr1

Sound is working on iphone 6 plus on iOS 10.2

but on both ipad 2 - iOS 9.3.5

and Ipad mini - iOs 10.2

It only works with headphones plugged in it doesn't work with the speakers.

This was working before Christmas as I tested on both devices. Is there some sort of call to an external server or script in the encrypted plugin that has been updated or changed?

The ipad mini has had an iOS update in late December just after iOS 10.2 came out but the ipad 2 did not and will not but still exhibits the same problem. Again though unless an external script is being called it doesn't really make sense. Got a couple of big projects that are currently using this plugin and it's less than ideal to say the least that users on ipads can't listen to audio without headphones. :(
There is NO call to an external server in my script!

To work surround sound you always need min. 2 speakers.

Get some link to test example. Without examples nothing can be done.

best regards

Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

130

Tuesday, January 24th 2017, 5:57pm

Hello
Having a similar problem to landrvr1

Sound is working on iphone 6 plus on iOS 10.2

but on both ipad 2 - iOS 9.3.5

and Ipad mini - iOs 10.2

It only works with headphones plugged in it doesn't work with the speakers.

This was working before Christmas as I tested on both devices. Is there some sort of call to an external server or script in the encrypted plugin that has been updated or changed?

The ipad mini has had an iOS update in late December just after iOS 10.2 came out but the ipad 2 did not and will not but still exhibits the same problem. Again though unless an external script is being called it doesn't really make sense. Got a couple of big projects that are currently using this plugin and it's less than ideal to say the least that users on ipads can't listen to audio without headphones. :(
There is NO call to an external server in my script!

To work surround sound you always need min. 2 speakers.

Get some link to test example. Without examples nothing can be done.

best regards

Piotr
Hi Piotr

Thanks for getting back to me, I didn't mean to cause offence by asking if there was a call to an external script, I was merely asking if there was as the main file is encrypted. I'll PM you the link to the tour and username and password as it's not in public domain yet.

It's just a really hard thing to test for as I develop on PC and test then up to server to then test on different devices and just so strange that it's working on iphone and desktop but not on ipads. Or rather it is working on ipads but only when headphones plugged in. I've probably done something stupid in my code somewhere. *smile*

131

Tuesday, January 24th 2017, 6:17pm

Hello
Having a similar problem to landrvr1

Sound is working on iphone 6 plus on iOS 10.2

but on both ipad 2 - iOS 9.3.5

and Ipad mini - iOs 10.2

It only works with headphones plugged in it doesn't work with the speakers.

This was working before Christmas as I tested on both devices. Is there some sort of call to an external server or script in the encrypted plugin that has been updated or changed?

The ipad mini has had an iOS update in late December just after iOS 10.2 came out but the ipad 2 did not and will not but still exhibits the same problem. Again though unless an external script is being called it doesn't really make sense. Got a couple of big projects that are currently using this plugin and it's less than ideal to say the least that users on ipads can't listen to audio without headphones. :(
There is NO call to an external server in my script!

To work surround sound you always need min. 2 speakers.

Get some link to test example. Without examples nothing can be done.

best regards

Piotr
Hi Piotr

Thanks for getting back to me, I didn't mean to cause offence by asking if there was a call to an external script, I was merely asking if there was as the main file is encrypted. I'll PM you the link to the tour and username and password as it's not in public domain yet.

It's just a really hard thing to test for as I develop on PC and test then up to server to then test on different devices and just so strange that it's working on iphone and desktop but not on ipads. Or rather it is working on ipads but only when headphones plugged in. I've probably done something stupid in my code somewhere. *smile*
I've now semi solved the problem although still not sure why it's happening got into a coding Spiral last night trying to solve this but just found this post re iOS Web Audio - http://stackoverflow.com/questions/21122…s-on-headphones

As it turns out both ipads I was testing on had their side buttons set to mute. It didn't affect the sound from the videoplayer plugin though only your plugin.

Although it means there's no problem with code it's still strange how and why this only effects some tours using the plugin and not others on ipads with the mute switch on. Very Happy I don't have to spend another night till 2am sifting through my code though *smile*

132

Wednesday, January 25th 2017, 1:05am

I'll add once again (and confirmed in that link from streetvisit) that this is an issue on the iPhone as well.

133

Sunday, January 29th 2017, 11:07pm

Piotr, any new thoughts or info on this? Seems like it's an iOS problem so not sure if there's anything that can be done on your end?

spacerywirtualne

Professional

  • "spacerywirtualne" started this thread

Posts: 873

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

134

Monday, January 30th 2017, 10:23am

Hi
Piotr, any new thoughts or info on this? Seems like it's an iOS problem so not sure if there's anything that can be done on your end?
What exactly the problem you have in IOS? Paste a link here and I check on the IOS directly to your project.

Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

135

Wednesday, February 1st 2017, 7:01pm

Hey Piotr, caught in a deadline but when I wrap it up I'll try and recreate the problem then post a step by step. Tnx

spacerywirtualne

Professional

  • "spacerywirtualne" started this thread

Posts: 873

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

136

Friday, February 17th 2017, 11:16am

Hi *smile*


I sent to all clients a link to download the latest version of the plugin (ver 2.2)

* update Howler JavaScript files
* resolved conflict width the incorrect scene names in the GUI edit mode

If you bought HTML5-VR Audio Plugin and not receive messages, email me.



We are constantly working on improving our plugins. Any suggestions are welcome.


Kind regards

Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

137

Friday, May 26th 2017, 5:42pm

Problem with background sound and WebVR mode

Hi many compliments for your very useful plugin.

I've made a tour with 4 scenes and I've setup the beckground music for each one (the same sound file).
All works fine when I see the tour in normal mode (each scene have its background sound) except when I switch into VR mode: here I heard the sound only for the first scene, when I load the other no sounds at all.

Here my sound.xml file generated with the edit mode:

<krpano>

<sound2d>

<scene name="scene_p1_l" audiofile="background" vol="0.8" rate="1.0"/>

<scene name="scene_p2_l" audiofile="background" vol="0.8" rate="1.0"/>

<scene name="scene_p3_l" audiofile="background" vol="0.8" rate="1.0"/>

<scene name="scene_p4_l" audiofile="background" vol="0.8" rate="1.0"/>


</sound2d>

</krpano>

I've missed something?

Thanks a lot.


Luca

spacerywirtualne

Professional

  • "spacerywirtualne" started this thread

Posts: 873

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

138

Friday, May 26th 2017, 9:15pm

Hello
Hi many compliments for your very useful plugin.

*squint*


I've made a tour with 4 scenes and I've setup the beckground music for each one (the same sound file).
All works fine when I see the tour in normal mode (each scene have its background sound) except when I switch into VR mode: here I heard the sound only for the first scene, when I load the other no sounds at all.


This is definitely not enough information. The best way to give a link or send me a ZIP with the project by a wetransfer.



Best regards
Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

139

Saturday, May 27th 2017, 12:55pm

Yes sure is a pleasure!

Here the Tour link:

http://demo.visual4d.it/VR_Playground/tour.html

At the same time I've sent you by Wetransfer the complete project.

Many many thanks for your help.

Regards.


Luca

spacerywirtualne

Professional

  • "spacerywirtualne" started this thread

Posts: 873

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

140

Monday, May 29th 2017, 10:20am

Yes sure is a pleasure!

Here the Tour link:

http://demo.visual4d.it/VR_Playground/tour.html

At the same time I've sent you by Wetransfer the complete project.

Many many thanks for your help.

Regards.


Luca
I checked your project (IOS and Android) and the sound works fine. Try clearing your browser's memory...

best regards
Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*