You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

21

Tuesday, September 5th 2017, 6:45am

Again this problem!

Unfortunately, with the latest update of Firefox (55.0.3) and Adobe Flash to 26.0.0.151 again appeared the "Adobe Flashplayer required!"
But now it does not help to make all the permissions for the Adobe player as described above.
Yes, the technology is dying, but it was very convenient to use the tour editor!
Maybe there is some solution? Nothing that was before - does not help ....
Sometimes earlier, when I ran the test server from the folder that Krpano was generating, I had a page in the browser where I could select the file to include. Now immediately opens the tour. Can I open folder with files in browser first, and from them I want to select viewer - not through test server?

22

Sunday, September 10th 2017, 7:35pm

Confirm that there is a problem with firefox :-(
In opera works yet, try it.

23

Monday, September 11th 2017, 8:43am

Hi,

Unfortunately, with the latest update of Firefox (55.0.3) and Adobe Flash to 26.0.0.151 again appeared the "Adobe Flashplayer required!"
Since the latest Firefox update the Flashplayer is blocked on file:// urls. But by opening the tour_editor.html via a localhost server (krpano testing serves) should still work. In Chrome the using via the testing server would also work when enabling Flash and adding the testing server IP-address once in the Chrome content settings (here: chrome://settings/content/flash).


Sometimes earlier, when I ran the test server from the folder that Krpano was generating, I had a page in the browser where I could select the file to include. Now immediately opens the tour. Can I open folder with files in browser first, and from them I want to select viewer - not through test server?
Only the reduced 'tour_testingserver' opens the current folder and there the tour.html directly, the normal 'krpano Testing Server' doesn't open tour.html files by default automatically, there you can browse and manually open the files. Alternatively you can still anytime just enter 'tour_editor.html' in the browser url-bar.


Btw - about the problem itself:
In the next krpano release the tour editor will be integrated into the 'krpano Tools' application and be independent of the Flashplayer or Browser restrictions.

Best regards,
Klaus

24

Tuesday, April 24th 2018, 1:17pm

Hi,

as it seems the latest Flashplayer update a few days ago has disabled the possibility to load local xml files by default.

There are two possibilities:

1. Use a localhost server, e.g. like the included krpano Testing Server:
http://krpano.com/tools/ktestingserver/#top

2. Or adjust the Flashplayer security settings:
http://krpano.com/docu/localusage/#changesecuritysettings
E.g. add 'c:' (Windows) or '/' (Mac) as location, then all panos within these paths will be able to use the vtoureditor helper tool again.

Btw - there will be soon a new a krpano tool as replacement for the vtoureditor plugin. It will be a standalone tool and will work without Flash and without the Browser.

Best regards,
Klaus
First step it works. But I tryed the second and I cannot chose a folder. I did: Edit location/Add location/Browse for folder/ and when I browse, it doesn't let me chose a folder, only a file. The "Open" tab is active until I chose a file, not a folder. It is something I do wrong?

25

Wednesday, April 25th 2018, 9:23pm

Edit location/Add location/Browse for folder/ and when I browse, it doesn't let me chose a folder, only a file.

Right, that's a bug of the Flashplayer security setting editor. The path would need to entered directly/manually, choosing via dialog doesn't work.

But I would recommend better using the testing server - or even better the new tour editor that works without Flash:
krpano 1.19-pr13

26

Friday, November 23rd 2018, 12:18pm

Edit location/Add location/Browse for folder/ and when I browse, it doesn't let me chose a folder, only a file.

Right, that's a bug of the Flashplayer security setting editor. The path would need to entered directly/manually, choosing via dialog doesn't work.

But I would recommend better using the testing server - or even better the new tour editor that works without Flash:
krpano 1.19-pr13
Hello Kraus,

My tour_testingserver works perfectly on my desktop (windows).

However, when I sent the package to a client with a Mac computer (I don´t know the version), she couldn´t open the tour_testingserver_macos.
I have made the Tour with the krpano 1.19-pr16, so it should be working, right?

On the other hand, I don´t mind sending the client the Tour Editor, for her to use it instead of the tour testingserver. However it doesn´t allow to fullscreen the tour, which is a pity.

Can you help?

Thanks

27

Wednesday, November 28th 2018, 12:02pm

Hi,

However, when I sent the package to a client with a Mac computer (I don´t know the version), she couldn´t open the tour_testingserver_macos.
How do you send the files?
Maybe the tour_testingserver_macos file doesn't have executable permissions anymore...?


On the other hand, I don´t mind sending the client the Tour Editor, for her to use it instead of the tour testingserver. However it doesn´t allow to fullscreen the tour, which is a pity.
The Tour Editor will not work without demo-logo without license. Btw - why shouldn't the fullscreen mode work? (it does)

Maybe have also a look here for sending a client an easy to use tour:
Offline exe for client (without server)

Best regards,
Klaus