You are not logged in.

101

Tuesday, August 8th 2017, 1:11pm

Hi,

a - when entering webVR, the empty video goes fullscreen and i have to minimize manually to hide it, all the rest seems running fine.video screen : https://www.dropbox.com/s/m2q5qhduqukwu89/bug.pr12.mp4?dl=0
Only in your app, or?
Maybe the browser engine in your app works differently to Safari, but in Safari the hack should be working. The internal wakelock video itself has the 'playsinline' setting applied of course - and since iOS 10 this should be supported by iOS...

But when your already be in an own app I would recommend disabling the web wakelock hack:
https://krpano.com/plugins/webvr/#mobilevr_wakelock
and looking for an app native wakelock...


b - Bingmaps seems slower to load map tiles, the radar cannot be rotated by touch (all the map move)
That's due the new Bingmaps V8 API. For me it also fells a bit slower and less responsive and the touching on the radar (the radar is a polygon in the API) is also a bug of the API.

It's unfortunately necessary to use that API version. Microsoft has announced to turn-down the old V7 API - and According to the announcement it should be already down, but today it's still working... If you want to risk it, you could still use the V7 API by either using an older bingmaps.js plugin version or adding - v8api="false" - in the xml to the bingmaps <plugin> element.

About the issues (slow, radar touching) itself - they can be fixed only on Microsofts side, but once fixed they would become automatically available as the API will be loaded from the Microsoft servers.


but i have to report, that with each update i have to clean out permissions and quarantine flags on osx. for example when copying manually from the template folder, the plugins cant get loaded later because they all have permissions of 700. i guess you fix that on the fly when using the droplets, but it would be nice to have correct permissions and quarantine flags removed for all files also in the templates/viewer folders...
I think these flags get automatically added by the OSX system itself when manually copying or moving files from signed images - and the DMG image itself need to be signed to allow starting the apps in OSX Sierra and higher...
The tools/droplets itself don't add or change any flags when copying the files.
So I'm not sure if it would be possible to do here anything but I will check that...

102

Tuesday, August 8th 2017, 1:51pm

If the text is Chinese, then the webgl textfield hotspot will be a problem. Chinese is wrapped in a single character,This means that as long as there is a character to the right side, it should be wrapped。
Sorry, I know you had already reported that problem, but unfortunately I have forgotten to note that...
But I have already done tests with that and it seems that problem can be fixed by allowing to break after each character for certain unicode-codepage-ranges. I still need to do more tests with other languages and other cases, but I think in the next release this should be fixed.

Best regards,
Klaus

103

Wednesday, August 9th 2017, 1:24pm

Quoted

But when your already be in an own app I would recommend disabling the web wakelock hack:
https://krpano.com/plugins/webvr/#mobilevr_wakelock
and looking for an app native wakelock...


Thanks,
the app is made with cordova, i think there wakelock plugin too... i'll look into that *smile*

z

104

Friday, August 18th 2017, 10:14am

bug report!

scrolltocenter action just like settocenter,you can see that in corfu vtourskin

mischi

Beginner

Posts: 8

Location: dortmund

  • Send private message

105

Tuesday, August 22nd 2017, 1:52pm

Radar

Hi, bin mir nicht sicher ob es ein Bug ist, oder ich etwas falsch mache.. Das Radar-Plugin in der BingMap dreht sich genau entgegengesetzt zur Drehrichtung des Panoramas.

Beste Grüße! *smile*

Posts: 89

Location: Fairfax, CA

Occupation: Code-Slave

  • Send private message

106

Friday, August 25th 2017, 3:54am

pr12 iOS 10.3.3 video bug

This only happens in pr12, I've tested it in pr11 and pr10 and everything works as expected.

In the case of using a 360video as the image for a scene, when I call the following action to pause the video and load another scene I get a black screen and everything locks up.
The error reporting out of tethered-inspection via Safari yields:

Anonymous Script1
Line 308:27 null is not an object (evaluating 'a.paused')


function E(a) {
m.ios && !0 !== a.paused && (g.iOS_current_video = a)
}


Source code

1
2
3
<action name="stop_transhub"> 	plugin[transhub].pause();    loadpanoscene('scene_xml.php?sceneid=123654&tourid=1345&load=trans',scene_myscene    ,null,MERGE|KEEPVIEW|KEEPMOVING,BLEND(1));
	if(webvr.isenabled,    set(hotspot[transhub_stop].visible,false);    set(hotspot[transhub_pause].visible,false);    );
	transcomplete();</action>

107

Wednesday, August 30th 2017, 2:11pm

Hi,

bug report!
scrolltocenter action just like settocenter,you can see that in corfu vtourskin
Sorry, but I don't see a bug or problem...
What do you mean?


Hi, bin mir nicht sicher ob es ein Bug ist, oder ich etwas falsch mache.. Das Radar-Plugin in der BingMap dreht sich genau entgegengesetzt zur Drehrichtung des Panoramas.
Stimmt, bei der Berechnung wurde sin/cos vertauscht und dadurch stimmt die Position und Drehrichtung nicht. Sorry, das ist mir leider irgendwie nicht aufgefallen... In der nächsten Version wird dies natürlich behoben sein. Als Workaround wäre es möglich v8api="false" zum <plugin> Element hinzuzufügen.


his only happens in pr12, I've tested it in pr11 and pr10 and everything works as expected.
In the case of using a 360video as the image for a scene, when I call the following action to pause the video and load another scene I get a black screen and everything locks up.
The error reporting out of tethered-inspection via Safari yields:
Anonymous Script1
Line 308:27 null is not an object (evaluating 'a.paused')
function E(a) {
m.ios && !0 !== a.paused && (g.iOS_current_video = a)
}
Thanks for the report - this will be fixed in the next release.

Best regards,
Klaus

ninerian

Beginner

Posts: 40

Location: Zwickau

Occupation: Softwareentwickler

  • Send private message

108

Monday, September 4th 2017, 9:14am

Fatal Error in krpano Tools

Hello,

when I open the krpano tools in OSX 10.12.16, the error:

Fatal Error:

Missing File: /private/var/folders/..../d/krpanotools

Can I fix this anyway?

109

Monday, September 4th 2017, 10:11am

Hello,
Missing File: /private/var/folders/..../d/krpanotools


i guess thats app translocation
try again after moving your krpano folder out of the downloads folder

AntonSorok

Beginner

Posts: 7

Location: Moscow

  • Send private message

110

Monday, September 11th 2017, 12:22pm

invalid expression krpano

In krpano 1.18 i wrote this function and everything was ok. But when i rewrite tour in 1.19 i get this error. Next function in onnewscene


if(scene[get(xml.scene)].pan=='20'
or scene[get(xml.scene)].pan=='21'
or scene[get(xml.scene)].pan=='25'
or scene[get(xml.scene)].pan=='26'
or scene[get(xml.scene)].pan=='27'
or scene[get(xml.scene)].pan=='28'
or scene[get(xml.scene)].pan=='29'
or scene[get(xml.scene)].pan=='41'
or scene[get(xml.scene)].pan=='42'
or scene[get(xml.scene)].pan=='51'
or scene[get(xml.scene)].pan=='52'
or scene[get(xml.scene)].pan=='53'
or scene[get(xml.scene)].pan=='54',
set(plugin[slider].visible,true);
if(muzforest==='0',
playsound(music6,forest.mp3,loop);
set(muzforest,1);
setvolume(val);
,
resumesound(music6);
setvolume(val);
);
,
set(layer[slider].visible,false);
if(muzforest==='1',
pausesound(music6);
set(birds,0);
);
);


Everything work if I use 1 panorama, but it's don't work when i write or ..... or What is this problem with? Thank you.

spacerywirtualne

Professional

Posts: 866

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

111

Monday, September 11th 2017, 2:09pm

Everything work if I use 1 panorama, but it's don't work when i write or ..... or What is this problem with? Thank you.
I don't know but maybe a lowercase 'or' is a problem.

https://krpano.com/docu/actions/#expressions


try:

if(scene[get(xml.scene)].pan=='20'
OR scene[get(xml.scene)].pan=='21'
OR scene[get(xml.scene)].pan=='25'

...


Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

AntonSorok

Beginner

Posts: 7

Location: Moscow

  • Send private message

112

Monday, September 11th 2017, 2:31pm

Everything work if I use 1 panorama, but it's don't work when i write or ..... or What is this problem with? Thank you.
I don't know but maybe a lowercase 'or' is a problem.

Everything work if I use 1 panorama, but it's don't work when i write or ..... or What is this problem with? Thank you.
I don't know but maybe a lowercase 'or' is a problem.

https://krpano.com/docu/actions/#expressions


try:

if(scene[get(xml.scene)].pan=='20'
OR scene[get(xml.scene)].pan=='21'
OR scene[get(xml.scene)].pan=='25'

...


Piotr
Yes, I have try this with topcase OR but same error. I think this problem of 1.19

AntonSorok

Beginner

Posts: 7

Location: Moscow

  • Send private message

113

Monday, September 11th 2017, 8:11pm

Everything work if I use 1 panorama, but it's don't work when i write or ..... or What is this problem with? Thank you.
I don't know but maybe a lowercase 'or' is a problem.

Everything work if I use 1 panorama, but it's don't work when i write or ..... or What is this problem with? Thank you.
I don't know but maybe a lowercase 'or' is a problem.

https://krpano.com/docu/actions/#expressions


try:

if(scene[get(xml.scene)].pan=='20'
OR scene[get(xml.scene)].pan=='21'
OR scene[get(xml.scene)].pan=='25'

...


Piotr
Yes, I have try this with topcase OR but same error. I think this problem of 1.19
i have find mistake. I have update js, swf in 1.18 again and this function start work *attention*
But, when i change again to 1.19 this code don't work *attention* Therefore this is an error of krpano 1.19. Klaus, fix it please.

114

Monday, September 11th 2017, 9:35pm

Hi,

the lowercase 'or' is the problem - only uppercase operator names (e.g. OR AND) are supported (at least in version 1.19).

Lowercase operators might have worked in version 1.18, but that was never be documented or officially be supported. In version 1.19 the expression system was fully rewritten and extended with more possibilities and there for simplify-reasons only uppercase operators were implemented. With the next release I will also update the documentation to note explicitly about that the operators need to in UPPERCASE.

Best regards,
Klaus