You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

61

Tuesday, January 16th 2018, 6:34pm

Nothing to show. Just follow this 3 steps.

62

Tuesday, January 16th 2018, 6:40pm

step 2. open it and change URL to something like this: http://192.168.0.13:64544/tour.html#123
step 3. reload the browser page
Get an error: ERROR: copy(startscene,scene[0].name) - invalid variable name: 123

Hi,

that's not directly an error, but the error message is wrong/unrelated.

When passing a query parameter (after a ? or # in the url), then the basic syntax to set/pass variables is:

Source code

1
tour.html?variable=value&variable=value&...
but the '=value' is optional, it also possible just to define a variable without value.

and that is what is happening here - that call tries to defined a variable named '123' - but that's an invalid name.

The error message is wrong because that happens at an 'unexpected' state/time.

Best regards,
Klaus

63

Tuesday, January 16th 2018, 6:54pm

But I don't what to setup any variable. Who knows what can be in browsers hash after #.
For example I used hash for deeplinking, but since pr13 I get such warnings.
Is there any way to disable setting variables at all?

64

Tuesday, January 16th 2018, 7:00pm

Is there any way to disable setting variables at all?
Yes - just set the passQueryParameters setting in the html file to false (or remove the setting):
https://krpano.com/docu/html/#passQueryParameters

65

Tuesday, January 16th 2018, 7:09pm

Thanks its works!
However there is no documentation how to setup vars with #hashes
IMHO query_string is enough for it but hashes need to be leaved for customs purposes

66

Tuesday, January 16th 2018, 7:59pm

Is there any way to set passQueryParameters to false after player is embeded with passQueryParameters:true?

67

Tuesday, January 16th 2018, 10:53pm

However there is no documentation how to setup vars with #hashes
IMHO query_string is enough for it but hashes need to be leaved for customs purposes
I had to admit I wasn't aware too that '#hash' values were parsed as well. They were used as alternative when no '?query' values were present in the url.
In the next release this will be removed - then only the query values will be passed (when the related setting is enabled).

s there any way to set passQueryParameters to false after player is embeded with passQueryParameters:true?
How do you mean that?
The url parsing and the passing the url variables to the viewer happens only ONCE at the embedding of the viewer...

benji33

Intermediate

Posts: 244

Location: France

Occupation: Senior Software engineer

  • Send private message

68

Wednesday, January 17th 2018, 9:24am

When Simulated VR mode is activated on Chrome desktop (PC) when rotating with the mouse on Yaw axis the view is refreshed at a previous position during "quick" rotations. Works good on Firefox.

Many users report a difficulty to access a tour through the WebVR API with the Samsung Internet Browser for GearVR. It works great with the Oculus Browser.
Do you know the difference between the 2 differents browsers? It seems that the Oculus Browser has a better use of the available resolution. John Carmack FB Post

69

Wednesday, January 17th 2018, 11:59am

In the next release this will be removed

Thanks

The url parsing and the passing the url variables to the viewer happens only ONCE at the embedding of the viewer...

Oh! sure! sorry was drunk ;)

70

Wednesday, January 17th 2018, 8:25pm

When Simulated VR mode is activated on Chrome desktop (PC) when rotating with the mouse on Yaw axis the view is refreshed at a previous position during "quick" rotations. Works good on Firefox.
Sorry, can't reproduce anything like that. Just tested again (on Windows).
Can you please explain your 'quick' rotations?

Many users report a difficulty to access a tour through the WebVR API with the Samsung Internet Browser for GearVR. It works great with the Oculus Browser.
Do you know the difference between the 2 differents browsers? It seems that the Oculus Browser has a better use of the available resolution. John Carmack FB Post
Right, the Oculus Browser has way better WebVR support - but for the technical details please contact the browser developers! From krpano side everything is the same of course. The rendering is done via the WebVR API and there the browser is doing the VR rendering.

jeromebg

Professional

Posts: 729

Location: Angers - France

Occupation: Photographer

  • Send private message

71

Wednesday, January 17th 2018, 9:14pm

Quoted from "benji33"
When Simulated VR mode is activated on Chrome desktop (PC) when rotating with the mouse on Yaw axis the view is refreshed at a previous position during "quick" rotations. Works good on Firefox.
Sorry, can't reproduce anything like that. Just tested again (on Windows).
Can you please explain your 'quick' rotations?

I have the same issue with Chrome 63, when fake vr mode is enabled the view.hlookat resets to it's initial value while moving the mouse.

72

Wednesday, January 17th 2018, 11:19pm

I have the same issue with Chrome 63, when fake vr mode is enabled the view.hlookat resets to it's initial value while moving the mouse.
Do you have the Chrome developer tools opened while testing this?
If yes - this is the problem - Chrome has a pointer-lock bug with opened developer tools.

With closed dev-tools I can't reproduce a problem, but there are some other (non-krpano) posts about a pointer-lock problem on the web - so maybe there is really a new Chrome bug here:
http://www.html5gamedevs.com/topic/34516…ith-windows-10/
http://www.html5gamedevs.com/topic/34523…g-in-chrome-63/

Btw - 'pointer-lock' is the name of the browser api for this control mode:
https://developer.mozilla.org/en-US/docs…ointer_Lock_API

Kabkee

Trainee

Posts: 82

Location: South Korea

Occupation: South Korea

  • Send private message

73

Thursday, January 18th 2018, 2:38am

log window color change.

according to the current update,
log window is too bright to see. since that , ever time i see the logs i have to drag and have all text been highlighted.
:(

May i change the color or any other options for it ?

74

Thursday, January 18th 2018, 9:05am

you're talking about the krpano log, activated by pressing "O", right?
it is always black opaque with white text... how can it be that you cant read it?
maybe a screenshot?

benji33

Intermediate

Posts: 244

Location: France

Occupation: Senior Software engineer

  • Send private message

75

Thursday, January 18th 2018, 9:32am

Sorry, can't reproduce anything like that. Just tested again (on Windows).
Can you please explain your 'quick' rotations?


Here is a video sample with closed Chrome dev tools : https://www.dropbox.com/sh/dq9jntg58uo9z…tpIn4lxPma?dl=0
Thanks for the answer to jeromebg.

This post has been edited 1 times, last edit by "benji33" (Jan 18th 2018, 9:46am)


Kabkee

Trainee

Posts: 82

Location: South Korea

Occupation: South Korea

  • Send private message

76

Thursday, January 18th 2018, 9:40am

you're talking about the krpano log, activated by pressing "O", right?
it is always black opaque with white text... how can it be that you cant read it?
maybe a screenshot?
Is everyone having the same style as old as usual?
Check mine out in the attetchment.


77

Thursday, January 18th 2018, 10:00am

uh that looks strange... are you on 1.19?
i've never seen that...
maybe klaus knows whats going on w your tour

Kabkee

Trainee

Posts: 82

Location: South Korea

Occupation: South Korea

  • Send private message

78

Thursday, January 18th 2018, 10:11am

uh that looks strange... are you on 1.19?
i've never seen that...
maybe klaus knows whats going on w your tour
Yes, it's 1.19 pre14. most updated one.
I assumed that it's a new feature because its style is set using inline style attribute.
.... strange... and hard to see.. :(

79

Thursday, January 18th 2018, 10:50am

Is everyone having the same style as old as usual?
Check mine out in the attetchment.
Looks like some custom CSS styles that overwrite global element styles... (link to the example?)
krpano itself doesn't style the log this way of course ;-)

Kabkee

Trainee

Posts: 82

Location: South Korea

Occupation: South Korea

  • Send private message

80

Thursday, January 18th 2018, 11:00am

Is everyone having the same style as old as usual?
Check mine out in the attetchment.
Looks like some custom CSS styles that overwrite global element styles... (link to the example?)
krpano itself doesn't style the log this way of course ;-)
please, check out the link - https://look360.kr/vr/indyspot/indyspot_member/2521
I hope the link will work on your country as well.

press 'o' key will show the log.

Similar threads