You are not logged in.

1

Saturday, February 24th 2018, 12:23pm

Blending Modes

Hello,
I'm having trouble changing the blending mode to a 'Black-Out' style colorblend, and just wondering if there's something else I need to call in the .xml


At the moment the multiresolution Tour has this loadscene script:


<action name="startup" autorun="onstart">
if(startscene === null OR !scene[get(startscene)], copy(startscene,scene[0].name); );
loadscene(get(startscene), null, MERGE);
if(startactions !== null, startactions() );
</action>


And I have tried:


<action name="startup" autorun="onstart">
if(startscene === null OR !scene[get(startscene)], copy(startscene,scene[0].name); );
loadscene(get(startscene), null, MERGE, COLORBLEND(2.0, 0x000000, easeOutSine));
if(startactions !== null, startactions() );
</action>


Is there something else I need to call?
Running 1.19 pr.14
Any help much appreciated,
Dan

2

Saturday, February 24th 2018, 1:44pm

Hi,

change the 'loadscene_blend*' settings in the <skin_settings> element in the tour.xml.

The vtourskin.xml uses the settings from there for the pano-blending.

Best regards,
Klaus

3

Sunday, February 25th 2018, 7:03am

Ahh - thanks Klaus!
This is now working beautifully between panoramas in the tour.
One thing though - I'm still not sure how to colorblend tween in (from black) on the very first (opening) pano of the tour?
Many thanks,
Dan

4

Wednesday, February 28th 2018, 10:55am

Hi,

krpano can only blend between panos/scenes - that means when loading the first scene there will be no blending.

But that could be faked by defined by black preview grid and blending from that to the first scene with a little delay.

E.g. try this in the tour.xml:

Source code

1
2
3
4
5
6
7
8
9
<preview type="grid(cube,1,1,1,0,0,0)" />

<!-- startup action - load the first scene -->
<action name="startup" autorun="onstart">
	wait(0.1);
	if(startscene === null OR !scene[get(startscene)], copy(startscene,scene[0].name); );
	loadscene(get(startscene), null, MERGE, COLORBLEND(2.0, 0x000000, easeOutSine));
	if(startactions !== null, startactions() );
</action>


Additionally set the 'loadingtext' setting to "" in the <skin_settings> to avoid a wrong loading text at the beginning.

Best regards,
Klaus