You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,154

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

1

Tuesday, March 20th 2018, 5:53pm

switch between flat and 360

Hi,

i find an issue with the video player. The issue is with resizing, conform the stageheight and width at a certain moment.
- When i use it as flat video player: works nice
- when i go from flat video to 360 video, all is fine.

But when i want, after it is used for 360 video, use for flat video again i can't find how to make it work good again.
I mean that when i resize the screen, it seems that the video player doesn't get the 'align' (= center) when i resize the screen.

i tried setting all settings as before, also panovideo to false again etc etc.. but it doesn't behave as i would expect in this case.
Also tried updatescreen():

Is this a know issue?
Or a bug?


feels like the stage is messed up or so. .. align is center, but when i resize the browser it doesn't stay in center.
Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

This post has been edited 1 times, last edit by "Tuur" (Mar 20th 2018, 6:10pm)


Tuur

Sage

  • "Tuur" started this thread

Posts: 3,154

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

2

Thursday, March 22nd 2018, 1:59pm

Hi,

i made a simple dirty bare bone example.

http://www.virtualtuur.com/krpano/video-flat-360-flat/1/

- click me
- watch the flat video and RESIZE the browser screen how it behaves
- onvideocomplete 360 video will show.
- onvideocomplete flat video comes again.. RESIZE the browser screen to see the problem.

I try to use the same video player for flat and 360 in a project but going back from 360 to flat seems to be 'problematic'.

Where do i go wrong or what could be the problem, issue, bug?

xml's:
http://www.virtualtuur.com/krpano/video-…flat/1/tour.xml
http://www.virtualtuur.com/krpano/video-…videoplayer.xml

Of course using 2 videoplayers works perfect as alternative, but i was especially interested in the above.

Cheers!
Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

This post has been edited 1 times, last edit by "Tuur" (Mar 22nd 2018, 6:46pm)