You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

benji33

Intermediate

  • "benji33" started this thread

Posts: 244

Location: France

Occupation: Senior Software engineer

  • Send private message

1

Thursday, May 3rd 2018, 3:49pm

Flying picture and hotspot with child layer issue

Hi,

I've tried to setup a picture hotspot with a flying attibute. It works.
I've added a hotspot which is covered by the flying picture, with the add of zorder/zorder2 values (flying picture receive a zorder of 10 and hotspot a zorder value of 3). It works.

But

If I add a text layer created with the addlayer method as child of the previous hotspot, the hotspot itself and the layer are always over the flying picture even with all zorder changes.

Is it a known issue with children layers ?

Thanks,
Benjamin

jeromebg

Professional

Posts: 729

Location: Angers - France

Occupation: Photographer

  • Send private message

2

Friday, May 4th 2018, 11:28am

Layers are always over hotsptos

benji33

Intermediate

  • "benji33" started this thread

Posts: 244

Location: France

Occupation: Senior Software engineer

  • Send private message

3

Friday, May 4th 2018, 4:35pm

Thanks so it's why my hotspot with tooltip layer is over the flying hotspot picture.
I'll have to manage a way to set tooltip as hotspot, simple, but apply offset and rotation linked to the hotspot one, with non defined picture size it will be more difficult to achieve *unsure*