Sie sind nicht angemeldet.

41

Mittwoch, 18. April 2018, 10:39

I'm sorry to hear this about the LG browser's video mode, but not surprised. How did you determine it?
By testing and logging ;-).
The browser itself is just a 'full-hd' application, it doesn't utilize the 4k resolution of the TV. You can see that also by normal browsing when looking at the pixel raster. I assume this is done for performance reasons, webpage rendering in 4k would make the TV browser even slower ;-).
This is at least the case a 2015 and a 2016 LG TV model that I've tested, maybe newer ones or TV browsers from other manufacturers are better here...

That browser also crashes on panos with large cubeface sizes, so is really not much use.
With multires any sizes should be possible.

But by using the TV as a 4k 3D monitor, we should still be able to show interlaced stereo from web pages.
Yes.

42

Samstag, 21. April 2018, 04:58

Hi!

I'm experiencing some strange things with this version. Is it possible that because of the changes in encryption this viewer only accepts js/xml files encrypted with this, current version of krpanotools?

43

Mittwoch, 25. April 2018, 21:21

I'm experiencing some strange things with this version. Is it possible that because of the changes in encryption this viewer only accepts js/xml files encrypted with this, current version of krpanotools?

No, the viewer itself is fully backward-compatible.

That means loading files with older encryptions is always possible, only the other way doesn't work - when encrypting files with the new encryption method from 1.19-pr15/pr16, then they can't be loaded in older versions.

But when there is a problem, please post a link to an example or send it directly to me.

Best regards,
Klaus

44

Donnerstag, 26. April 2018, 04:33

Sent you an email. Thanks!

45

Donnerstag, 26. April 2018, 14:07

Sent you an email. Thanks!
Sorry, but no email here...

46

Donnerstag, 26. April 2018, 16:09

Right, cause gmail blocked it. Sent it again, it seems this time it went through. Thanks!

Beiträge: 79

Wohnort: Fairfax, CA

Beruf: CTO

  • Nachricht senden

47

Sonntag, 29. April 2018, 20:58

Krpanotools encrypt -stdout issues pr15 - followup

Klaus,

I finally have more datapoint to submit.

I’ve “upgraded” to pr16 and this issue still persists.

I’m 99.99% sure what is happening here is that the system( encrypt ) command on line 25 of the code I posted in my prior/original post is erring at seemingly random times.
I know the file that I’m trying to encrypt does exist, because of the if(file_put_contents) qualifier and the fact that the file remains because of the if ( $theoutput ) qualifier for the unlink statement. And I know the file is a valid XML file because I’ve run them through several XML validators which return the file as “clean”.

The random description is warranted because this error CAN happen with any of 700+ tours we have that leverage the same code-set. And this can happen once and then won’t be experienced again for several days by a user. Or it might happen several times in a row.

This error is the one place I can’t really handle for an error ( I don’t think ) because the -out=stdout echoes/writes to the file polluting the xml that could be echoed after the attempt to encrypt.

The issue seems to be most prevalent on mobile devices, from my own testing. However I have reports of the error happening on desktop Chrome and Safari. No one has reported the error in FireFox.

When a sess_ref cooke is available ( basically a session ID ) I’m able to back trace the error to my analytics capturing database.
The user agents that I can directly link/verify to an error are:
Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36
Mozilla/5.0 (Linux; Android 8.0.0; SM-G955U1 Build/R16NW) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.106 Mobile Safari/537.36
Mozilla/5.0 (iPhone; CPU iPhone OS 11_2_1 like Mac OS X) AppleWebKit/604.4.7 (KHTML, like Gecko) Version/11.0 Mobile/15C153 Safari/604.1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36
Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

I personally have witnessed the error on iPhone 7+ under Safari & Chrome but can’t seem to view the error under FireFox or Edge, on this same device.

48

Montag, 7. Mai 2018, 14:38

Dear Klaus,

we've updated to the latest version, now the issues with the gyro are thankfully gone. However, it seems that some default behavior is changed perhaps? So far we had a code that changed (switched) the enabled property of the gyro plugin after it became available, because that's how the gyro function could be enabled automatically on startup. With the new version it seems that this changed, as our code now results in disabling it automatically.

It's not a big issue as it was a 1-minute fix for us, just thought I'd ask if I diagnosed this correctly, as the documentation still says that the plugin is not enabled by default.

Or maybe there's a different reason to this phenomenon, one I didn't think of?

49

Dienstag, 8. Mai 2018, 11:00

I'd ask if I diagnosed this correctly, as the documentation still says that the plugin is not enabled by default.
There was no change here and the gyro plugin is disabled by default.

50

Dienstag, 8. Mai 2018, 11:09

Hi,

The random description is warranted because this error CAN happen with any of 700+ tours we have that leverage the same code-set. And this can happen once and then won’t be experienced again for several days by a user. Or it might happen several times in a row.
Sorry, but for me that sounds more like a server-side problem...
What happens on your side when there a two requests to the same file at the same time?
Do you do some file locking and checking for locked files to prevent any runtime conflicts?
E.g. one PHP request process might currently write a file, while another one reads the same file...