Sie sind nicht angemeldet.

Scott Witte

Fortgeschrittener

  • »Scott Witte« ist der Autor dieses Themas

Beiträge: 221

Wohnort: Milwaukee, WI USA

Beruf: Professional Photographer

  • Nachricht senden

1

Dienstag, 10. Juli 2018, 01:37

KRPano on Sharepoint Online/O365 +IE11 not working?

A client is trying to deploy my tour on a Sharepoint Online/O365 server and running into problems. I have zero experience with this and hope someone here can help. Here are the notes I got from their IT:

Zitat

Please note that the files you have provided were in HTML format which is not supported in Sharepoint Online/O365.

Hence we have converted them to .aspx files (Valid / Supported file format in O365).

The tour file is working fine in Google Chrome, however it fails in IE browser. Upon further analysis we could find that the files provided are forced to open in IE Edge mode however it works fine upon degrading the document mode. Attached screenshots for reference.

Please update the files accordingly and provide us the correct version to upload in the Portal.

By my understanding you "convert" .html to .aspx just by changing the extension.

I have <meta http-equiv="x-ua-compatible" content="IE=edge" /> in the header. This just tells IE to run at the highest level possible (not as the Edge browser). If you are using IE11, that is how it will render. Curiously, in IE11 their emulation shows "Edge." (see below.) Mine shows "11." What really seems to be happening is that the pathing got messed up so none of the pano files loaded. But downgrading to IE10 emulation "fixed" that. And it wasn't a problem viewing in Chrome.

Thier screen grab:


If you have experience with Sharepoint, does any of this sound familiar?

2

Dienstag, 10. Juli 2018, 09:43

Hi,

looks like a CORS problem...

Just as note:
- IE10 = CSS3D => and CSS images are not limited by CORS (because there is no access to the pixeldata in this case)
- IE11 = WebGL => images loaded to WebGL require CORS permissions (because this way it would be possible to access the pixeldata)

First make sure that CORS is enabled on the server from where you load that data:
https://enable-cors.org/server.html

Additionally try also this setting:

Quellcode

1
<security cors="use-credentials" />

In some cases the IE browsers requires the setting 'use-credentials' instead of the default 'anonymous' for some reason... (=browser bug).

Best regards,
Klaus

Scott Witte

Fortgeschrittener

  • »Scott Witte« ist der Autor dieses Themas

Beiträge: 221

Wohnort: Milwaukee, WI USA

Beruf: Professional Photographer

  • Nachricht senden

3

Dienstag, 10. Juli 2018, 18:14

Zitat

looks like a CORS problem...

Will pass that on, make the code update and see if that helps.

Really, really, glad you know something about this. Totally out of my wheelhouse.

Thanks!

4

Dienstag, 28. August 2018, 09:51

Hi Klaus

That solved my problem also but only on tours made in the latest krpano version.
Is there a fix for tours made in 1.18.2 ?

Thanks
Marcin