You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, February 19th 2018, 9:16pm

krpanotools x64 crash

Hello Klaus!

I'm using the krpano tools as an external (command line) program from an Adobe AIR based desktop app. So far it has worked fine, but lately I've been experiencing some crashes. All I get is the following info:

Problem signature:
Problem Event Name: APPCRASH
Application Name: krpanotools64.exe
Application Version: 0.0.0.0
Application Timestamp: 5a217a8b
Fault Module Name: StackHash_f1da
Fault Module Version: 6.1.7601.18247
Fault Module Timestamp: 521eaf24
Exception Code: c0000374
Exception Offset: 00000000000c4102
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1038
Additional Information 1: f1da
Additional Information 2: f1daa28eb1693c528e3761282611ec6f
Additional Information 3: eeb2
Additional Information 4: eeb2c3206cbe7c2100648d2800165afe


The exit code (which should normally be 0) from the executable is: 3221226356.


This happens on Windows 7, x64, but my clients say the same happens on Win10 too. Any idea what's going on?

This post has been edited 1 times, last edit by "webseta" (Feb 20th 2018, 1:12am)


2

Tuesday, February 20th 2018, 2:18am

Too early to tell (still testing), but it might be that turning off the jpegoptimize in the config file might have stopped the crashes!

3

Wednesday, February 21st 2018, 2:44pm

No, sadly it didn't help. Klaus can you please look into this? This is causing some serious issues for us now.

4

Wednesday, February 21st 2018, 11:40pm

Hi,

can you provide a reproducible test-case?

Best regards,
Klaus

5

Thursday, February 22nd 2018, 5:16am

I'll check, although I'm afraid that might be hard because as it seems, it's quite random which image it crashes on (we're feeding the tools a massive boatload of images, one at a time of course). I was hoping the error log Windows provided me might be of some use, but again, I'll try to narrow the issue down. Stay tuned.

herrpedro

Trainee

Posts: 140

Location: Lisbon

Occupation: Programmer/analyst

  • Send private message

6

Tuesday, October 2nd 2018, 7:49pm

hi
i had a crash encrypting a file for some days now
whe i was splitting the file in pieces so i could see what bit was causing it i found a bunch of code that was nos in the xml and not in comments (it was a comment but only had end.. not start)
i added the start in the comment and all went well
don't know if it is your case