You are not logged in.

simon64

Beginner

  • "simon64" started this thread

Posts: 34

Location: uk

Occupation: architectural illustrator

  • Send private message

1

Monday, January 28th 2019, 9:39am

playing a mp3 sound file over a videopano mp4 with vol set at '0'

I'm trying to run a videopano in a loop but i want a different sound source than anything that i might embed into the mp4 video itself.
The reason for this is that my video is a short 4 seconds loop (rushing water) and to avoid a sound jump every 4 seconds i have made a longer, separate, mp3 sound file that i'd like to run as a background sound.
Having a longer stretch of sound before any jump is less worrying with this longer loop.

Anyway i can only get the video working but not the sound.
I seem to have tried all sorts of variations with the code but with no luck.
Can anyone help me spot the problem in my code here below ?

or of course if anyone has a better idea of how i can achieve what i'm after.

(not sure if it has anything to do with it, but i'm using chrome)





<krpano version="1.19" title="Virtual Tour">

<include url="skin/videointerface.xml" />


<plugin name="soundinterface"
url.flash="%SWFPATH%/plugins/soundinterface.swf"
url.html5="%SWFPATH%/plugins/soundinterface.js"
preload="true"
rootpath=""
volume="1.0"
mute="false"
/>


<action name="startup" autorun="onstart">
if(startscene === null OR !scene[get(startscene)], copy(startscene,scene[0].name); );
loadscene(get(startscene), null, MERGE);
if(startactions !== null, startactions() );
</action>



<scene name="videopano" title="" onstart="playsound(bg,'wheelsound.mp3, 0')">


<plugin name="video"
url.html5="%SWFPATH%/plugins/videoplayer.js"
url.flash="%SWFPATH%/plugins/videoplayer.swf"
pausedonstart="false"
loop="true"
volume="0"
onloaded="add_video_sources();"
/>

<image>

<sphere url="plugin:video" />
</image>

<view hlookat="0" vlookat="0" fovtype="DFOV" fov="130" fovmin="75" fovmax="150" distortion="0.0" />


<action name="add_video_sources">
videointerface_addsource('3000x1500', '%CURRENTXML%/wheel.mp4');

videointerface_play('3000x1500');
);
</action>

</scene>

</krpano>