Sie sind nicht angemeldet.

Joel

Anfänger

  • »Joel« ist der Autor dieses Themas

Beiträge: 8

Wohnort: Innsbruck, Austria

Beruf: Interaction- and webdesigner

  • Nachricht senden

1

Dienstag, 12. Februar 2019, 11:14

accelerometer/gyroscope sensor access disabled -> will Cardboard VR still work on iOS 12.2?

Hi Klaus,

Quoted

According to an article discussing iOS 12.2 beta features:

> Accessing sensor APIs is now disabled by default, so no accelerometer, gyroscope or magnetometer APIs are working unless the user enables a Settings option under “Safari”
Does this mean Cardboard VR mode won't work anymore in iOS 12.2? *blink*

I have read through this discussion: https://github.com/w3c/deviceorientation…mment-458464696
Which sounds like they might create a popup asking the user for permissions, but perhaps not in time.

Tuur

Erleuchteter

Beiträge: 3 042

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

2

Dienstag, 12. Februar 2019, 11:45

Hi,

i think it means that the user first needs to enable the setting before it can use gyro etc..
Which is a nasty and very users unfriendly thing.
I really hope there can be a workaround.
I do quite much government to public information tours for landscape planning stuff, and i'm afraid all these people need to first change these settings on their device, which could stop them to visit.
A pop-up could be best solution for this stupid thing, when it changes the setting by one click. And i hope the pop-up is not to just say that the user needs to go there and there and do this this and this to change it.. *cursing*

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Tuur

Erleuchteter

Beiträge: 3 042

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

3

Donnerstag, 14. Februar 2019, 18:09

i updated to latest OSX and see some things changed.
I use space bar for play pause in 360 video .. also to test in fake webvr mode.
Now it suddenly change the hlookat to 0 every time i click spacebar.

also in a bit more complex situation when i exit vr on desktop it tweens automatically vlookat to 0... wondering why and also why i don't see this when i only use standard webvr xml...


edit: i narrowed it down and of course some is my own 'sloppy-ness' but when i use spacebar when in fake vr to play pause on desktop it sets on every key hit the hlookat to 0.. Why is that? i'm quite sure it was not like that before my OSX update..

It was not like this..
Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Tuur« (14. Februar 2019, 23:10)


4

Freitag, 15. Februar 2019, 09:34

Morning!
I'm also really worried about this! Just read about it in macrumors and looked for a krpano forum post immediately...
This would probably render a lot of tours out there useless (on iOS) and we would have to update all of them *cursing*
As i know apple, they won't make it as simple as providing a popup to allow people to bypass this new "security" "feature"...

5

Freitag, 15. Februar 2019, 16:18

Hi,

in the current iOS 12.2 beta versions the gyro support is disabled by default in Safari.

The only way to enable it at the moment would be:
[Homescreen] => [Settings] => [Safari] => enable the motion/orientation access setting

That means that feature will be basically not available for common users with that iOS version.
This affects the gyro plugin and the webvr plugin.

A better solution (beside of keeping to allow sensor usage for the main page) would be for sure a permission dialog to ask the user if the page is allowed to use the gyroscope/acceleration sensors, but I doubt that Apple will do that in that version. Maybe and hopefully in later iOS versions...

One good thing is that other iOS browsers - e.g. Firefox or Chrome are unaffected by that Safari change and are still allowing gyroscope/acceleration sensor usage by default.


edit: i narrowed it down and of course some is my own 'sloppy-ness' but when i use spacebar when in fake vr to play pause on desktop it sets on every key hit the hlookat to 0.. Why is that? i'm quite sure it was not like that before my OSX update..
Sorry, but that doesn't seem to be related - the webvr.xml was always using the SPACE key for 'reseting' the sensor (setting back to 0). Have a look in the webvr.xml for this line and remove it:

Source code

1
onkeydown="if(webvr AND webvr.isenabled AND keycode==32, webvr.resetSensor() );"


Best regards,
Klaus

Tuur

Erleuchteter

Beiträge: 3 042

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

6

Gestern, 08:46

Thanks Klaus,
I totally forgot or missed that...
There is so much to it.
I’m glad that that is the issue and not something else.

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur