You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Davide

Beginner

  • "Davide" started this thread

Posts: 3

Location: Prague

Occupation: Software Developer

  • Send private message

1

Saturday, March 2nd 2019, 12:50pm

WebVR: View locked to cursor when loading scenes

Hi all,

I created a simple VR tour with krpano 1.19-pr14, with hotspots to navigate between scenes, using the webvr.xml plugin defaults.

The action for loading a new scene is triggered by the hotspots' onclick event.

The call to the krpano API is:

Source code

1
loadscene(%1, null, MERGE, OPENBLEND(0.5, 0.0, 0.75, 0.05, linear));



It's working, but during the transition the view of the scene I'm leaving gets somehow locked to the cursor, so if I move my head during the whole panorama follows me, in an unpleasant way.

This doesn't happen with a VR tour created using krpano's droplet tool, yet I don't see what is different between my and its code.

Any ideas?

Thanks

2

Saturday, March 2nd 2019, 3:24pm

Hi Davide,

try instead of only 'MERGE':

NOPREVIEW|MERGE|KEEPVIEW|KEEPMOVINGSteve

3

Monday, March 4th 2019, 11:58am

Hi!

I have similar problem, when i during the transition to next scene, panorama follows me and when I move my head I have got black strips around pano, huh ? Is it performance bug ? I have got default krpano webVR settings.

4

Wednesday, March 6th 2019, 10:09am

Hi,

as shown above the 'KEEPMOVING' flag would need to be used.

But when using an actual krpano version and a actual vtourskin.xml, this would get added automatically for VR mode...

Best regards,
Klaus