You are not logged in.

Dear visitor, welcome to Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Monday, June 10th 2019, 2:14am

(SOLVED) VR mode starts distorted, Settings crash the first time (tested on multiple iOS devices)

When VR mode is entered for the first time on a new device, this happens: very very strong zoom? *blink* When I try to go to settings, the tour freezes. Next time, VR mode is still distorted, but in the second or third attempt, a new device can be chosen and it works from then on.
Some kind of havesettings error? Thanks!!!!

This post has been edited 1 times, last edit by "MIshaPetla" (Jun 11th 2019, 1:54pm)


Monday, June 10th 2019, 4:28pm

Oh and I've tried removing ask_user... "ondeviceunknown"…tings#post78402
Problem persists, tour starts ok on "custom", but the second you try to change the headset, crash. Next time (when buffer is not emtpy anymore?), it works ok.
I'm guessing problem lies somewhere in vr_setup action?
@klaus, any input would be most welcome, thx in advance


Monday, June 10th 2019, 10:29pm

I don't think the problem can be solved by adding another device to
the database; I'm running the tour as a standalone app, for ios and
android, so external sources, in this case a database, are unavailable.
The problem exists on all newer iphones (I am testing with iPhone
Simulator and Xcode).
Potential solutions I think are:
  • tweaking onunknowndevice parametres in index_core_vr. xml
  • disabling default VR "device-blank", or setting one of options as default
  • creating
    a settings file in advance, that way havesettings would return true.
    Only "blank" creates the problem; or not having a settings file

What do you guys think?


Tuesday, June 11th 2019, 1:54pm

Add this to onentervr, in webvr.xml or index_core_vr.xml. And remove ask user for screensize, and if sentence on onunknowndevice.

Not sure if all of this is needed, but it does the trick for me. I'm guessing the empty cache used to crash vr settings, now something gets written; no longer empty:)

copy(hs, vrheadsets.headset1);

copy(vrs, webvr.vrsetup);