You are not logged in.

Dear visitor, welcome to Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Friday, July 12th 2019, 4:22pm

bombtimer scene to scene stopped working

Hi, I have just noticed that my Auto next scene bombtimer on tours has stopped working. The tour was created using krpano-1.19-pr14, i have tried downloading pr16 to see if it helps but still nothing:
Here is the tour
The xml is here
<!-- startup action - load the first scene -->
<action name="startup" autorun="onstart">
if(startscene === null OR !scene[get(startscene)], copy(startscene,scene[0].name); );
loadscene(get(startscene), null, MERGE);
if(startactions !== null, startactions() );

<action name="startup">
if(startscene === null, copy(startscene,scene[0].name));
loadscene(get(startscene), null, MERGE);

<action name="bombtimer">
delayedcall(1, bombtimer(get(bt)));
if(bt == 42, set(bt,0); nextscene();, );

<action name="nextscene">
set(ns, get(scene[get(xml.scene)].index) );
set(maxs, get(scene.count) );
if(ns == maxs, set(ns,0);, );
loadscene( get(scene[get(ns)].name ), null, MERGE, BLEND(1.5) );

<autorotate enabled="true" waittime="1.5" accel="1.0" speed="10.0" horizon="0.0" tofov="off"/>

Not sure why it would have stopped, can anyone shed any light?
Many thanks in advance.

Scott Witte


Posts: 344

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message


Saturday, July 13th 2019, 7:00am

Without giving too much thought I would suggest putting a trace in the bombtimer action that reports the bt variable to help see what is happening and when. Traces are good for that sort of thing.


Saturday, July 13th 2019, 10:04am


Thanks Scott, i solved it this morning. Somewhere along the line when i updated to a newer version i omitted to put in onstart="bombtimer(0); startup();"> so the script was not being read :( All ok now.