You are not logged in.

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,164

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

1

Tuesday, September 3rd 2019, 1:13pm

playsound_at_hotspot Question

Hi,

i am playing a bit with the new sound interface, which is great, and i was wondering if i make a stupid mistake.
It seems the sound goes the wrong way, when i just listen on my laptop.

https://www.virtualtuur.com/krpano/120/s…und_at_hotspot/
https://www.virtualtuur.com/krpano/120/s…otspot/tour.xml

Click cow hotspot or C to play audio.
Turn the pano so that the cow is outside the middle.
When the cow goes to the right the sound goes to the left.. *cry*

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

This post has been edited 2 times, last edit by "Tuur" (Sep 3rd 2019, 2:59pm)


spacerywirtualne

Professional

Posts: 899

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

2

Tuesday, September 3rd 2019, 2:15pm

There is no spatial effect at all on Google Chrome (76.0.3809.132 64bit).
On Firefox (68.02) there is this error - audio right instead of left.

Piotr
Your own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: youtube

cms4vr team *thumbsup*

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,164

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

3

Tuesday, September 3rd 2019, 2:32pm

mmm. strange.. i only checked on safari mac until now, there it seems to work, but the other way around-ish

get this error on firefox (mac)
Error: WebGL warning: getContext: Disallowing antialiased backbuffers due to blacklisting.
Works though, but also wrong direction.
The error you mention i don't get

Quoted

There is no spatial effect at all on Google Chrome (76.0.3809.132 64bit).
On Firefox (68.02) there is this error - audio right instead of left.

Is the above normal? Or my fault?

Not sure what to do or where to go.
May be i should stay at the normal 'playsound' with my other big 'little fun' project.
I think the code is quite straight forward.

Anybody?

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

This post has been edited 2 times, last edit by "Tuur" (Sep 3rd 2019, 4:41pm)


Tuur

Sage

  • "Tuur" started this thread

Posts: 3,164

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

4

Tuesday, September 3rd 2019, 6:16pm

ok,

i tried with playsound_at_hv and set the depth to -1000.
https://www.virtualtuur.com/krpano/120/s…laysound_at_hv/

seems to work for my need now, but i'm quite unsure if this is supposed to be like this and if i understand correctly.. i doubt it.
*unsure*
but on mac/chrome it seems to work for half a second and then the sound just goes in the center.

https://www.virtualtuur.com/krpano/120/s…_at_hv/tour.xml

edit:... maybe i confuse 3d sound with 2d directional sound..mm..

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

This post has been edited 3 times, last edit by "Tuur" (Sep 3rd 2019, 7:58pm)


5

Saturday, September 28th 2019, 4:44am

i think there is a bug with plugin! @klaus

There is no spatial effect at all on Google Chrome (76.0.3809.100 64bit) & 77.0.3865.90.
On Firefox (69.01) OK!has spatial effect

6

Saturday, September 28th 2019, 2:41pm

Hi,

there will be soon a fixed version, then spatial 3d sounds will work in all browsers and there will additional support for a 'directional' sound volume range.

Best regards,
Klaus

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,164

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

7

Saturday, September 28th 2019, 4:00pm

*love* *love*

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur