You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, October 27th 2019, 12:24pm

How to use the same tiles for 2 tours?

Hello, I need advice on how to use the same tiles for 2 tours. I have tour #1 in Italian, and tour #2, which is a copy of #1, in English; of course the tiles are the same, so I'd like to set the xml file of tour #2 to use the tiles contained in tour #1 indexdata folder. Any idea on how I can get this? I tried to do as stated in this guide:
http://www.kolor.com/wiki-en/action/view/Panotour_-_Advanced_-_Different_interfaces_for_different_devices#Option_3_-_Two_tours_on_the_same_server_with_redirection
but there's something wrong as I always get an error message and nothing is displayed on screen. Thanks a lot.
Alessandro

2

Monday, October 28th 2019, 9:16am

Hi,

basically all you need todo is the set the correct urls (relative or absolute) to the tiles in the xml files.

And if doing access across domains then also CORS on the server need to setup correctly - more information about that here:
https://enable-cors.org/server.html

Best regards,
Klaus

3

Monday, October 28th 2019, 12:31pm

Thanks for your reply, that's what I thought, but the problem is I can't do that.

I tried to modify the xml file of Tour #2, which is contained in the main folder of Tour #1 (next to its indexdata):
1) in the krpano tag, I added a line: basedir="./../indexdata/"
2) in each <scene> tag I replaced thumburl="%FIRSTXML%/..." with thumburl="%BASEDIR%/..."
3) in each <preview> tag I replaced url="%FIRSTXML%/..." with url="%BASEDIR%/..."
4) in each <imagee> tag I replaced url="%FIRSTXML%/..." with url="%BASEDIR%/..."

But all I get is the attached error message. Can you please help me?
Thnaks again,
Alessandro
rosco27 has attached the following image:
  • 2019-10-28_12-25-51.jpg

4

Monday, October 28th 2019, 5:57pm

Hi,

the error message just indicates that the paths might be still wrong.

Maybe try also using the browser developer tools to find out more which paths are finally tried to get loaded.

Best regards,
Klaus

5

Tuesday, October 29th 2019, 12:39pm

Update. Maybe this can be useful to other beginners like me who need any kind of possible help.
It works. The error message I got was probably due to krpano Testing Server, that I was using to view the tour offline. It seems that KTS can't open properly a tour with tiles located in a different folder than the one where the xml file is.
But when the tours are uploaded online, everything works correctly, thanks to the changes to the xml file I listed in post #3.