You are not logged in.

1

Tuesday, November 26th 2019, 4:47pm

VR and gyroscope icons disappeared in my mobile phone

I’m using krpano 1.20.2 version. At first, everything works fine, but when I upload the files to the server in order to see the VR tour with my mobile phone, I can’t see neither the gyroscope nor the VR glasses icons, so that I can’t turn on the VR mode.

In case I open with the same mobile phone a VR tour made some months ago, it works fine. I tried to make the tour with krpano 1.20.2 and also with previous version 1.19-pr16 and in both cases the issue is the same.

I think it’s not a failure of Google Chrome, as it opens older VR tours fine. I can’t find the solution.
frangarcia has attached the following images:
  • Captura_krpano-1.jpg
  • Captura_krpano-2.jpg

This post has been edited 2 times, last edit by "frangarcia" (Dec 4th 2019, 7:42pm)


2

Tuesday, November 26th 2019, 5:14pm

best post the link to your tour

spacerywirtualne

Professional

Posts: 929

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

3

Tuesday, November 26th 2019, 5:35pm

HTTPS enabled?

Piotr
Your own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: youtube

cms4vr team *thumbsup*

4

Tuesday, November 26th 2019, 6:30pm

no it isnt .... if we get 5cents for each of these gyro reports we are rich :D

@ francarcia :

try httpS://www.matradi.com/vr/191121benageber/

5

Tuesday, November 26th 2019, 7:18pm

No... it doesn't work. If I type this link in my mobile phone (Android + Google Chrome), the problem persists.

spacerywirtualne

Professional

Posts: 929

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

6

Tuesday, November 26th 2019, 7:59pm

I think it works

here is the proof *thumbup*

Piotr
Your own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: youtube

cms4vr team *thumbsup*

7

Tuesday, November 26th 2019, 11:23pm

Many thanks for your time, Piotr.

Effectively, it works in your phone. I'll try to guess why mine is not working...

spacerywirtualne

Professional

Posts: 929

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

8

Tuesday, November 26th 2019, 11:31pm

Effectively, it works in your phone. I'll try to guess why mine is not working...
If it doesn't work, it's only because you connect to the project using HTTP rather than HTTPS. Check it, it definitely works.
Do as indexofrefraction wrote. Open you r project from this link

regards
Piotr
Your own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: youtube

cms4vr team *thumbsup*

9

Wednesday, November 27th 2019, 10:14am

Yes! You are right!

The problem is that in my mobile phone, I don't know why, If I type this link in Google Chrome:

www.matradi.com/vr/191127benageber/

Then it goes to the link

http://www.matradi.com/vr/191127benageber/

Rather than

https://www.matradi.com/vr/191127benageber/

So that I have to “force” it to go to the https link. A big THANKS for your help!