You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,386

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

1

Wednesday, December 11th 2019, 3:12pm

Apple Catalina htpasswd..

Hi,

it seems with the latest OSX Catalina the .htpasswd script in Safari browser keeps on asking for the password.
Anyone aware about a fix or reason?

Tuur *thumbsup*

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,386

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

2

Friday, December 13th 2019, 12:36pm

Ok,

i made an example.
https://www.virtualtuur.com/apple/safaribug/1/
username: apple
password: 1234

when you play with the pano for 10-20 secs, zoom a bit, it starts asking for the password again, then it keeps asking.
I have the feeling that it has to do with the loading of the tiles.
Sometimes it shows black parts, and i get errors on loading the tiles.
In chrome and firefox all seems fine.

I also made a simple flat html page.. That seems to work just fine.. also in safari.

Before Osx Catalina i didn't have this issue.
I have contact with apple now, but like to know which change there makes krpano 'choke' (?)..

Any clue?
Tuur *thumbsup*

EDIT: adding <security cors="use-credentials" /> to the xml fixes the password issue.. but it seems i still got loading tiles issues after a while.

This post has been edited 1 times, last edit by "Tuur" (Dec 13th 2019, 2:01pm)


Tuur

Sage

  • "Tuur" started this thread

Posts: 3,386

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

3

Saturday, December 14th 2019, 12:52pm

Also issues importing .mov files in to premiere and aftereffects.
Better don't update to Catalina!!

Tuur *cursing*

Similar threads