You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, March 11th 2020, 3:03pm

color correction of distorted hotspot video

Hi!

So we've been trying to add some greenboxed video elements over the panorama. Following the tutorial available in these forums we have cut out a part of the panorama, and added it back as a distorted image hotspot. It's seamlessly integrated back, as expected.

However, when trying to use the same image as a background for a video, no matter what our video editing guys tried, the colors always seem to be ending up different, making it obvious where the edges are.

I've tried to search the forums for some solutions, and I saw that several ppl had trouble with this in the past, but couldn't really find any specific solutions to this.


Thing is, when we color-pick the video it seems to be ok, so is it just the way krpano plays the videos back? Any ideas on how to solve this?
panopan has attached the following image:
  • video color issue.png

2

Friday, March 13th 2020, 10:36am

Bump. Anyone? *unsure*

3

Friday, March 13th 2020, 1:02pm

Hi,

it unfortunately depends on the Brower and the system how videos are rendered.

E.g. on a Windows system with a Nvidia GPU you can adjust in the system settings the video-range (0-255 or 16-235) and also the color settings.
And video-encoding setting (also about the color range) also have an influence.

I'm not sure if there is currently an universally working technical solution possible with the current browser APIs...

As first step maybe try using different video encoding settings and color formats...

Best regards,
Klaus

4

Saturday, March 14th 2020, 10:21am

Thank you very much! We'll look into that.

5

Tuesday, March 24th 2020, 9:04pm

Hooray! A chance for me to give back to this wonderful community.
I think I have a solution for you that is deceptively simple. I too have been inserting distorted stereoscopic video hotspots that mesh perfectly with the <image> panos and ran into your color correction issue. In my case it was caused by the re-encoding from the video editing software. My solution was to simply load the equarectangular pano into the video software and export the pano with the same encoding settings, making the entire pano's colors match the video outputs! It is an additional step that can take a lot of time if your video software has a max resolution limit, but the results are really impressive.

The attached photo is a screenshot of the tour being viewed in Google Chrome and in there is the boundary between the hotspot video and the pano background. I know it is there, but I can't really see it. I would love to share the full tour with you, but it has not been approved to be released to the public yet :(

Good Luck!
Just Another Joe has attached the following image:
  • boundry between video and pano.jpg