You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Friday, May 29th 2020, 5:35pm

problem with hotspot position after upgrading from 1.18.3 to 1.20.6

Recently we upgrade from version 1.18.3 to 1.20.6 and rec-creating some virtual tours we noticed some problems with hotspot positioning.
ath and atv values are exactly the same but hotspot seems rotated of some degrees (180 degrees tipically).
I tried to compare main xml configuration files generated with each version and I saw that new version adds prealign option to images while older version does not.
Removing prealign option manually doesn't solve my problem.
How can we solve the problems?

It seems that new version need some tweaking but we don't know which files must be modified.
We use standards files schema for generate vt (like the one availiable in the samples) adding very basic options (watermarks and some speed regulation)

Thank you in advance

2

Saturday, May 30th 2020, 10:46am

HI, I found the solution.
these are the settings to prevent the problem I saw:

Source code

1
2
prealignheading=false
autolevel=off




Hope this helps someone
Bye

3

Thursday, July 16th 2020, 10:39am

I think I might have a problem like this. Where should I put the "prealignheading=falseautolevel=off"? Sorry, I'm new to programming.

4

Friday, July 17th 2020, 9:40am

HI, it depends on how you set up your build script.
Referring to standard vtour make script those params must be added in vtour_skin.config
Hope this help you