You are not logged in.

HansNyb

Professional

Posts: 1,019

Location: Denmark

Occupation: Photographer

  • Send private message

201

Monday, June 8th 2020, 8:12am

The fullscreen support for iPad is enabled (white-listed) for iOS 13.4 and higher now.


Actually it is activated also with 13.3.1 However it works very bad.

I just bought a new iPad Air which came with 13.3.1 and fullscreen button was activated. The problem was that zooming did not work.
It kind of jumped back when you zoomed in.
After updating to 13.5.1 it works.

While in 13.3.1 I did some testing an found also this weird bug. Tapping on the image gave me this popup. I have not been able to reproduce it in 13.5
It is actually a Zoom image which is opened fullscreen from a popup
https://www.360-foto.dk/fullscreen-bug.jpg

202

Monday, June 8th 2020, 10:25am

Hi,

Actually it is activated also with 13.3.1
Hmm... the fullscreen support is definitely only enabled for iOS 13.4 and higher...
Do you maybe enable it manually in the xml?
Look for a 'fullscreensupport' code line.


However it works very bad.
Agree, that's why it disabled by default for these iOS versions ;-). That popup is also a part of the strange/bad iOS (before 13.4) fullscreen behavior.

Best regards,
Klaus

HansNyb

Professional

Posts: 1,019

Location: Denmark

Occupation: Photographer

  • Send private message

203

Monday, June 8th 2020, 2:10pm

Do you maybe enable it manually in the xml?
Look for a 'fullscreensupport' code line


No I checked 3 of my tours. And I just to be sure checked the skin directly on server.
They all has this


<layer name="skin_btn_fs" url="nav/full.png" align="right" x="202" y="1" scale="0.52" onclick="switch(fullscreen);" devices="fullscreensupport" />

<layer name="skin_btn_closefs" url="nav/exit.png" align="right" visible="false" x="202" y="1" scale="0.52" onclick="switch(fullscreen);" devices="fullscreensupport" />

<events name="skin_events" devices="fullscreensupport"
onenterfullscreen="set(layer[skin_btn_fs].visible,false);set(layer[skin_btn_closefs].visible,true);"
onexitfullscreen="set(layer[skin_btn_fs].visible,true) ;set(layer[skin_btn_closefs].visible,false);"
/>

This post has been edited 1 times, last edit by "HansNyb" (Jun 9th 2020, 8:32pm)


HansNyb

Professional

Posts: 1,019

Location: Denmark

Occupation: Photographer

  • Send private message

204

Tuesday, June 9th 2020, 10:30am

Hmm... the fullscreen support is definitely only enabled for iOS 13.4 and higher..


I discovered another thing. If I understand it right only Safari has the Fullscreen support on iPad.
I just downloaded Firefox and Chrome and even if none of them can do fullscreen, Firefox shows my Fullscreen button.

Another interesting thing for me is that if you make a Homescreen button in Safari the button is gone, also in my Krpano flat image xoom image.

There are more weird problems which I will come back to when I got all browsers tested.

205

Friday, June 12th 2020, 1:09pm

Dear Klaus!

Just discovered a potential bug in 1.20.6 and by the looks of it, 1.20.7. When using capturetouch=false (which we use in all tours because we have extensive html layouts), pinch-zooming on Safari/iOS zooms the whole...page. The tour is embedded fullscreen, so I'm not talking about a conventional website with an embedded tour. But 2D layers, buttons etc get zoomed and panned away too. Basically, as if the panorama and everything on it was a 2D image.

I can confirm that rolling back to 1.20.4 solves this, no problem there. Anyone else having this issue?

206

Monday, June 15th 2020, 11:39pm

Bug in bingmaps.js ?

Hi Klaus,

It seems that the plugin bingmaps.js does not treat the layer[skin_map].radar.visible right way:
When using settings.map_type=bing the HTML5 does not toggle the radar.visible attribute. It works well under FLASH and also in the googlemaps.js.
When the radar is hidden at the first scene, there is no way to display the radar anymore. When the radar gets shown at the first scene and I want to hide it next, the radar stays visible on the last instance.
(Win10: Firefox 75.0, Chrome 81, Edge 44, IE 11.0).

Thanks for your great job!
Pavel

207

Wednesday, June 17th 2020, 7:58pm

Hi Klaus,
Thanks a lot for your work, its really great. Unfortunatley I still have problems to view my vr tours made with VTOUR (VR-OPT) in Oculus Go (Browser 9.2...)
The Oculus Browser (unlike samsung or firefox on Oculus go) does not recognize my tour (made with 1.20.7) as VR. The Button "Enter VR" does not appear. When I set it manualy to VR360, it enters VR-mode, but displays only a distorted 180 degrees picture. I tried to find out something about this issue in the forum, but didnt find anything... Am I the only one with this problem, did I make a basic mistake??
Thx for your help
Try to add webxr: "auto" in embedpano and check that your oculus browser is not simulating desktop device.

I added webxr: "auto" in the tour.html, deleted the browser cache, made sure that the browser is not simulating desktop mode, but the problem is still there... *wacko*

208

Thursday, June 25th 2020, 7:54am

Hi,

I discovered another thing. If I understand it right only Safari has the Fullscreen support on iPad.
I just downloaded Firefox and Chrome and even if none of them can do fullscreen, Firefox shows my Fullscreen button.

One note - all these browsers now have also a 'Destkop Mode' (sometimes enabled by default) where they are faking their detection-information. So for krpano they look like a desktop browser and there is no information about the iOS version available anymore. So checking for the iOS version and removing the fullscreen support when known to be not usable anymore is not possible in this case. Additionally the iOS Firefox browser always reports that is fullscreen support, but when calling its APIs nothing happens.

The next krpano version will have some improvements here for even better detection, even when in fake Desktop-Mode, but to work everywhere the correct behavior from the browser itself is also a requirement.



Just discovered a potential bug in 1.20.6 and by the looks of it, 1.20.7. When using capturetouch=false (which we use in all tours because we have extensive html layouts), pinch-zooming on Safari/iOS zooms the whole...page.
Hmm... but that's the intended behavior of capturetouch=false - the touch events will be NOT captured by krpano and so the browsers default processing can happen...

Actually there was a bug in older krpano version (before 1.20.6), there the capturetouch=false setting was fully applied in all browsers. E.g. in iOS only the scrolling was blocked and only in some cases.

Here a quote from the 1.20.6 release notes:

Quoted

Fix: Allow the browsers default handling (panning, zooming) when using capturetouch=false.

So what behavior do would you actually use?


I added webxr: "auto" in the tour.html, deleted the browser cache, made sure that the browser is not simulating desktop mode, but the problem is still there... *wacko*
As there is no known problem, please share a link.

Best regards,
Klaus

HansNyb

Professional

Posts: 1,019

Location: Denmark

Occupation: Photographer

  • Send private message

209

Sunday, June 28th 2020, 4:21pm

One note - all these browsers now have also a 'Destkop Mode' (sometimes enabled by default) where they are faking their detection-information. So for krpano they look like a desktop browser and there is no information about the iOS version available anymore.


Both Chrome and Firefox Claims that ituses desktop as i Desktop.
Only Firefox shows the fullscreen button (which does not work.)
But both shows correctly my mobile help popup.

The weird thing is that if I request the Firefox mobile version it shows my Desktop Help screen.

210

Thursday, July 2nd 2020, 6:38pm

Hi all!
xml.scene return scene index not scene name when deeplinking="true" (this add /?startscene to URL and startscene variable is used). Is this old bug appeared again or there is some tricks?

211

Friday, July 3rd 2020, 11:26am

Hi,

xml.scene return scene index not scene name when deeplinking="true" (this add /?startscene to URL and startscene variable is used). Is this old bug appeared again or there is some tricks?

Currently the xml.scene variable always contains the value loadscene() was called with...

If you always want the scene name, use:

Source code

1
scene[get(xml.scene)].name


But I will consider doing that automatically in the next release to ensure that xml.scene always contains the name of the scene.

Best regards,
Klaus

213

Wednesday, July 8th 2020, 5:16pm

Hi,

When using droplets with 1.20.7 Mac, multires or vr-opt with Ricoh Theta Images, the tour wont go VR into Oculus (old and latest version).

The enter VR button appears, once clicked, the VR stays framed into the oculus browser window.

Thanks

214

Today, 9:41am

ok found out this happens when testing on a non https server

regards

Similar threads