You are not logged in.

1

Sunday, January 3rd 2021, 6:49pm

emulating google earth


I have assembled this sphere of the earth: (URL)?startscene=0&startactions=lookat(45,15,10,0,0);
I intend to see the globe in the middle of the black background, in the style of the beginning of Google Earth.

I got it (by chance) by modifying parameters in the URL, but now I don't know how to reproduce it again.
Some help?
Thank you

This post has been edited 3 times, last edit by "agufon" (Jan 4th 2021, 8:39am)


2

Monday, January 4th 2021, 9:42am

Hi,

not directly, but by using the non-stereographic fisheye view it would be at least possible to make something 'similar'...

Here an example using stereographic=false and fisheye=1.5:
https://krpano.com/krpano.html?pano=pano…view.fovmax=180

Best regards,
Klaus

3

Monday, January 4th 2021, 4:59pm

Solved (in part)

Thank you very much Klaus.
In https://ijlab.es/earth_br/index_bola.htm it is seen mounted with the parameter:

Source code

1
<view hlookat = "0.0" vlookat = "0.0" fovtype = "MFOV" fov = "120" maxpixelzoom = "2.0" fovmin = "70" fovmax = "140" stereographic = "false" fisheye = "1.5" />

On the other hand, I can't get the sphere to zoom out, to make it look smaller (although I can zoom in as much as I want) and I don't really know what parameter to touch anymore, because I modified the FOVs in various ways and did not achieve the goal.

Nor did I get that, when clicking on a place on the map, the view was zoomed in and the ball effect was lost.
Alternatively it could be something like a button for the ball view or not, toggling between both views.

Thanks a lot.

Mische

Trainee

Posts: 52

Location: dortmund

  • Send private message

4

Tuesday, January 5th 2021, 6:05pm

depthmapped earth

I intend to see the globe in the middle of the black background, in the style of the beginning of Google Earth.


You can also use a simple sphere as 3d-depthmap.
This example is just the "dollhouse-view".

No extra textures here, just depthmapped. But the panorama must be horizontally mirrored before, to show the earth correctly.

5

Tuesday, January 5th 2021, 8:35pm

I do something wrong ;-(

Thank you very much Mische.
I have downloaded a sphere in STL format and I have put the code that seems to have your example, but it does not work for me. ;-( https://ijlab.es/earth_br/index_bola.htm
Este es el código que le he puesto:

Source code

1
2
3
4
5
6
7
8
<scene name = "scene_mapamundi_br" title = "mapamundi_br" onstart = "" thumburl = "panos / mapamundi_br.tiles / thumb.jpg" lat = "" lng = "" heading = "">
<view hlookat = "0.0" vlookat = "0.0" fovtype = "MFOV" fov = "120" maxpixelzoom = "2.0" fovmin = "70" fovmax = "140" />
<preview url = "panos / mapamundi_br.tiles / preview.jpg" />
<image>
<cube url = "panos / mapamundi_br.tiles / pano_% s.jpg" />
<depthmap url = "panos / mapamundi_br.tiles / 300_polygon_sphere_100mm.stl" enabled = "true" rendermode = "3dmodel" background = "none" scale = "80" offset = "0.0" subdiv = "" encoding = "gray" axis = "+ x + y + z" cull = "twosided" center = "0,0,0" />
</image>
</scene>


Where this error? Is the stl not in the correct format?

Thank you

6

Tuesday, January 5th 2021, 10:25pm

why are you adding spaces everywhere ?
url = "panos / mapamundi_br.tiles / pano_% s.jpg" <--- this is not working
here is your code corrected:

Source code

1
2
3
4
5
6
7
8
<scene name="scene_mapamundi_br" title="mapamundi_br" onstart="" thumburl="panos/mapamundi_br.tiles/thumb.jpg" lat="" lng="" heading="">
    <view hlookat="0.0" vlookat="0.0" fovtype="MFOV" fov="120" maxpixelzoom="2.0" fovmin="70" fovmax="140" />
    <preview url="panos/mapamundi_br.tiles/preview.jpg" />
    <image>
        <cube url="panos/mapamundi_br.tiles/pano_%s.jpg" />
        <depthmap url="panos/mapamundi_br.tiles/300_polygon_sphere_100mm.stl" enabled="true" rendermode="3dmodel" background="none" scale="80" offset="0.0" subdiv="" encoding="gray" axis="+x+y+z" cull="twosided" center="0,0,0" />
    </image>
</scene>


ps your link doesnt use a depthmap

7

Tuesday, January 5th 2021, 11:20pm

It doesn't work for me. I do something wrong

Thank you very much for your correction.
The thing about the spaces may have been when pasting from the Dreamwearer, because in my code they were not.
For the rest, I must be doing something else wrong, because I have substituted what you happen to me in my scene and the screen is still black. It's maddening ;-(
Could the STL file be incorrect?

8

Tuesday, January 5th 2021, 11:30pm

your stl seems ok, but do you know that your xml doesnt use a depthmap ?
https://ijlab.es/earth_br/tour.xml

Mische

Trainee

Posts: 52

Location: dortmund

  • Send private message

9

Wednesday, January 6th 2021, 9:05am

Here:
https://ijlab.es/earth_br/tour_bola.xml

I think it is a problem with the stl:

The origin is at worldcenter, that is good, but it is not at center of the sphere.

Also add

Source code

1
oz="2000"
to the

Source code

1
<view/>
to see the globe from outside.

10

Thursday, January 7th 2021, 8:06pm

I have already made it work, but ...

I have already made it work, according to your advice: https://ijlab.es/earth_br/index_bolaxx.htm, however the image is upside down horizontally.
For the sphere I could solve it by reflecting the original image, but it would be better to get it by programming so that the image would be valid for the sphere and for the plane.

He was trying to see the flat map, setting up a second scene (as seen in https://ijlab.es/earth_br/) but instead it appears as a cube, with the map correctly oriented, but inside the cube in instead of flat. It's like keeping the 3D ;-(

I'll end up learning ;-), although maybe I want to do the impossible.

Similar threads