You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, September 26th 2021, 11:48pm

krpano 1.20.10

Hi,

after long time (sorry too long) here now a new release: krpano 1.20.10

It's just a minor release, but it's still important because iOS 15 has a few serious bugs that require workarounds.

Btw - why no big new release yet? I'm working currently in parallel on version 1.21 (many changes in the viewer, completely new layer and hotspot internals with more possibilities and features) and version 2.0 (complete new tools and new editing UI) and several parts there were unfortunately more complex than thought and so require also more time than expected. But therefore the new versions will offer also more than planed.

About the main changes in this release:
  • The iPhone Fullscreen Mode works again with iOS 15.
  • Layer elements with videos were invisible in iOS 15.
  • The WebGL depthbuffer accuracy of framebuffers got reduced with iOS 15 and Mac Safari 14 and that resulted in rendering artifacts (or black parts) when using 3D depthmapped panos together with post-processing effects or the WebVR lens-distortion.
  • In the default html template the passQueryParameters setting was set to true and that allows passing all kind of things to the krpano viewer by url query parameters. That could be used also for so called Cross-site-scripting attacks and the real risk of such possibility had to be considered rather low, but nevertheless it should be addressed of course. Therefore the passQueryParameters setting had been extended to allow now also only a limited list of parameters that can get passed. The default html template and the vtourskin.xml were updated for this - instead of the 'startactions' parameter, that allowed passing code, now a 'startlookat' parameter with numeric values is used. This prevents that custom code can be passed by url.


Update - 1.20.10 build 2021-10-01:
  • There is new build of version 1.20.10 available.
  • It uses now a different NWJS version for the Windows version, that one should run on more systems.
  • The WebGL depthbuffer accuracy for Mac Safari / iOS 15 was even more improved.
  • Additionally there is also new display.depthrange setting for optionally customizing the 3D rendering range (that should fit into the depthbuffer and be visible).
  • The embedding setting passQueryParameters=false caused a JS error in the previous release.
  • The webvr plugin has now a new wakelock workaround that works also on iOS 15.
  • And for the config files there is now a new setting 'outputpath' that allows quickly changing the output folder.


For all changes and more details please see here the Release Notes.

Best regards,
Klaus

panoyun

Trainee

Posts: 152

Location: Somalia

  • Send private message

2

Monday, September 27th 2021, 3:02am

*thumbsup* *thumbsup* *thumbsup*

juyatu

Beginner

Posts: 39

Location: China

Occupation: Krpano custom coding

  • Send private message

3

Monday, September 27th 2021, 5:02am

In Windows 11, the 1.20.10 exe files cannot be started, but the 1.20.9 exe files can work normally.
Does anyone else have the same problem?

This post has been edited 1 times, last edit by "juyatu" (Sep 27th 2021, 5:35am)


martyhr

Intermediate

Posts: 360

Location: CZ

  • Send private message

4

Monday, September 27th 2021, 9:47am

Perfect! I am looking forward to better handling and using multiple texture 3d model '( obj,tl,glb,glTF ) in the next version.
Thanks for 1.2.10 :-)

Tuur

Sage

Posts: 3,525

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

6

Monday, September 27th 2021, 10:53am

In Windows 11, the 1.20.10 exe files cannot be started

For me it works in Windows 11...
Do you get an error or something like that?

juyatu

Beginner

Posts: 39

Location: China

Occupation: Krpano custom coding

  • Send private message

7

Monday, September 27th 2021, 12:17pm

I don't really know why.Running as an administrator makes no difference.

1. On another Win11 computer,Convert SPHERE CUBE Droplet.exe,krpano Tools.exe,MAKE VTOUR Droplet.exe.None of them can be started and did not run after being clicked. However, Krpano Testing Server.exe started normally.
2, On the same computer, version 1.20.9 all can start normally.
3, On another Win10 computer, 1.20.10 can also start normally.



There are no errors. I just opened the EXE file, the mouse appeared 'rotate circle' means run, and stopped after 4 seconds. It was as if nothing had happened. *confused*

This post has been edited 3 times, last edit by "juyatu" (Sep 27th 2021, 12:55pm)


Tuur

Sage

Posts: 3,525

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

8

Monday, September 27th 2021, 12:24pm

Hi Klaus,

i just updated my 'tour', but the issue with the black squares in Safari browser seems still active.
I see it happening on desktop (Big Sur 11.6) and iphone (11pro) ios15.
No webvr or postprocessing plugins active when i see it.
Actually on iphone it seems to look better in VR mode then normal..
I took out the pp_blur.js effect, changed the plugins and tour.js.. uploaded.. cleaned cache few times..
I changed also the passQueryParameters:"startscene,startlookat"..

perhaps i forgot something?
I suppose there is nothing relevant to this in the depthmap-navigation and webvr xml's ..

If you like i can send you the link by email.


Tuur *thumbsup*

9

Monday, September 27th 2021, 2:25pm

Hi,

On another Win11 computer,Convert SPHERE CUBE Droplet.exe,krpano Tools.exe,MAKE VTOUR Droplet.exe.None of them can be started and did not run after being clicked. However, Krpano Testing Server.exe started normally.
The krpano Tools and the Droplets are the same tool and the only technical relevant change there is the update of the NWJS runtime. So maybe there is conflict between that new NWJS version and your hardware...
If you want you can contact me by mail, then I can send you builds with different NWJS versions for checking if that's the reason.


i just updated my 'tour', but the issue with the black squares in Safari browser seems still active.
Okay, yes, then I would need an example for checking that.

Best regards,
Klaus

10

Monday, September 27th 2021, 5:50pm

Hello Klaus.
Good luck to you and your work.
Thanks for the new version.
I wish you continued good work

Muhammed

Posts: 59

Location: Russia, Komi republic, Uhta

  • Send private message

11

Monday, September 27th 2021, 6:42pm

just recently in one of the chats we discussed the passQueryParameters parameter and its unsafe basis and harm to the tour) promptly)))

Fernando

Intermediate

Posts: 260

Location: Habana, Cuba

Occupation: Architect, Photographer.

  • Send private message

12

Tuesday, September 28th 2021, 3:20am

Thanks very much!!

I'm working currently in parallel on version 1.21 (many changes in the viewer, completely new layer and hotspot internals with more possibilities and features) and version 2.0 (complete new tools and new editing UI) and several parts there were unfortunately more complex than thought and so require also more time than expected. But therefore the new versions will offer also more than planed.


*thumbsup*

Posts: 59

Location: Russia, Komi republic, Uhta

  • Send private message

13

Tuesday, September 28th 2021, 5:46am

In Windows 11, the 1.20.10 exe files cannot be started, but the 1.20.9 exe files can work normally.
Does anyone else have the same problem?
same problem

Posts: 59

Location: Russia, Komi republic, Uhta

  • Send private message

14

Tuesday, September 28th 2021, 5:55am

If you want you can contact me by mail, then I can send you builds with different NWJS versions for checking if that's the reason.
Please send me different versions too, I'll check on mine. thanks

15

Tuesday, September 28th 2021, 10:16am

Win 7 prof - no start. None of the executable files just run. But I can see them in the Task Manager.

Posts: 59

Location: Russia, Komi republic, Uhta

  • Send private message

16

Tuesday, September 28th 2021, 10:20am

Win 7 prof - no start. None of the executable files just run. But I can see them in the Task Manager.
I can't see them in the Task Manager

17

Tuesday, September 28th 2021, 10:40am

Hi,

a bit strange these Windows problems, but okay, here two other builds with different NWJS versions for testing:

Once with NWJS 0.50.0-beta1 (Chromium 87 / Node.js v15.0.1) - the same as in 1.20.9:
Edit: file removed, the main version got updated

and here with NWJS 0.50.1 (Chromium 87 / Node.js v15.3.0)
Edit: file removed, the main version got updated

The current default download package is using NWJS 0.56.1 (Chromium 93 / Node.js v16.9.1).

Please let me known if one of these versions works for you!
On all my Window test systems, regardless if Windows 10 or 11, they work all the same.

Btw - The core krpano viewer and krpano tools itself are not affected by this, this NWJS only is only a web framework for showing the krpano Tools app user interface.

Btw2 - before starting make sure with the Task Manager that no krpano Tools.exe and no krpanotools.exe is still running.

Best regards,
Klaus

18

Tuesday, September 28th 2021, 11:01am

Win 7 prof - no start. None of the executable files just run. But I can see them in the Task Manager.
I can't see them in the Task Manager
In my case, every time I start the application, it stays in the Manager. There may be a lot of them ...

Posts: 59

Location: Russia, Komi republic, Uhta

  • Send private message

19

Tuesday, September 28th 2021, 11:18am

and here with NWJS 0.50.1 (Chromium 87 / Node.js v15.3.0)
Edit: file removed, the main version got updated
this version worked for me. thanks!

20

Tuesday, September 28th 2021, 1:32pm



Once with NWJS 0.50.0-beta1 (Chromium 87 / Node.js v15.0.1) - the same as in 1.20.9:
Edit: file removed, the main version got updated

This version worked in Win 7 Pro - everything started! Thanks and best wishes !!