You are not logged in.

1

Friday, November 6th 2009, 8:57am

Wavy Lines in equirectangular panorama

Hi. Is there any way I can get rid of the wavy lines in spherical panoramas? I've read that the main culprit is flash itself. When I generate the panorama in .mov format, everything is fine, but the flash version has many wavy lines. In the link below, look at the front panel of the CD player and at the nadir area. I've upgraded my flash player, but it's still the same. Any ideas?

http://www.autoevolution.com/testdrive/d…9/panorama.html

PS. I'm using ptgui, by the way.

michel

Professional

Posts: 1,153

Location: ANDORRA

Occupation: TV

  • Send private message

2

Friday, November 6th 2009, 12:05pm

Hi Tudor Raiciu,

There is a lot of thread asking about this.... Make a search for wavy lines....
Here an explanation from Klaus of the reasons for such waves: Suddenly getting wavy lines and ripples

SAlut.

3

Friday, November 6th 2009, 12:27pm

Thanks for the answer. One question though. I use an administration console for my equirectangular jpeg, where I load the file. After I've made the pano and converted to cubical, which renders 6 tiles, I'll have to load six separate files into the console, right?

4

Saturday, November 7th 2009, 12:23pm

After I've made the pano and converted to cubical, which renders 6 tiles, I'll have to load six separate files into the console, right?
Hi,

yes, convert it to cubical faces and load them in the xml:

Source code

1
2
3
4
5
6
7
8
<image type="CUBE">
  <left  url="pano_l.jpg" />
  <front url="pano_f.jpg" />
  <right url="pano_r.jpg" />
  <back  url="pano_b.jpg" />
  <up    url="pano_u.jpg" />
  <down  url="pano_d.jpg" />
</image>


best regards,
Klaus