You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, October 17th 2013, 10:24am

I have a question about video vr from android and ios condition.

Hello.


I use krpano Ver(1.16.8), this is played with desktop computer, but, doesn't played
normally with mobile equipment cellular phone(android (4.2.2), ios(7.0.2))what is the matter with this?
It is played like general video.
http://thevr.co.kr/gallery/video/sky/index.html

<krpano version="1.16.8">


<events name="backbutton_adjust" onxmlcomplete="if(layer[backbutton], set(layer[backbutton].y,80));" />

<include url="videointerface.xml" />

<!-- <layer name="videointerface_control_bar" width="100%" y="0" /> -->

<events onloadcomplete="delayedcall(2, if(layer[introimage], hideintroimage() ); );" />

<layer name="introimage"
url="skin/introimage.png"
align="center"
scale="0.8"
onloaded="set(alpha,0); tween(alpha,1.0);"
onclick="hideintroimage();"
keep="true"
/>
<action name="hideintroimage">
if(layer[introimage].enabled,
set(layer[introimage].enabled,false);
tween(layer[introimage].alpha, 0.0, 5.5, default, removelayer(introimage));
);
</action>

<view stereographic="true"
fisheye="1.0"
fov="100"
fovtype="VFOV"
fovmax="140"
fovmin="70"
hlookat="-60"
vlookat="100"
/>

<!-- load and control the video with the videoplayer plugin -->
<plugin name="video"
url="plugins/videoplayer.swf"
alturl="plugins/videoplayer.js"
loop="true"
posterurl="video/video.jpg"
onvideoready="videointerface_setvideo(get(name));"
/>

<!-- addtional settings for html5 to play the video as flat image -->
<plugin name="video" devices="html5" width="100%" height="prop" align="center" zorder="0" enabled="false" visible="false" onloaded="delayedcall(0.1, set(visible,true));" />

<!-- addtional settings for iOS/Android - paused at start -->
<plugin name="video" devices="ios|android" pausedonstart="true" />

<!-- set the video source file (different files and different paths for different devices) -->
<plugin name="video" videourl="video/video.mp4" devices="flash" />
<!--
<plugin name="video" videourl="video.webm" devices="firefox|chrome|opera" />
-->
<plugin name="video" videourl="video/video.mp4" devices="ios|android|blackberry|ie" />


<!-- define the pano image and get the pano video from the videoplayer plugin (flash only) -->
<image hfov="360" vfov="180" devices="flash">
<sphere url="plugin:video" />
</image>

<!--
<view hlookat="+300" vlookat="0" fov="120" fovtype="HFOV" fovmin="70" fovmax="140" limitview="range" vlookatmax="90" />
-->
<plugin name="krpanologo" url="skin/thevr.png" keep="true" align="rightbottom" x="5" y="5" alpha="1" scale="0.8" onover="tween(alpha,0.5);" onout="tween(alpha,1);" onclick="openurl(http://thevr.co.kr);"/>

<contextmenu><item caption="더 브이알 항공비디오VR 제작" separator="true" /> <item caption="항공촬영작가 - 우태하" separator="true"/> <item caption="Tel) 010.8866.8181" /> </contextmenu>
</krpano>
...............end...............

Give me a answer with this problem.
Thank you.

This post has been edited 3 times, last edit by "hermas" (Oct 21st 2013, 7:49am)


Umalo

Professional

Posts: 1,047

Location: Osijek, Croatia, EU

  • Send private message

2

Tuesday, October 22nd 2013, 1:39pm

<plugin name="video" videourl="video/video.mp4" devices="ios|android|blackberry|ie" />

I think there is the issue as you defined mp4 for ios, androdid, ..... and if you read documentation:
http://krpano.com/plugins/videoplayer/#html5
you will learn that mp4 is not supported by many HTML5 browsers.

Try with: videourl="video.m4v|video.webm|video.ogv" (prepare all formats ofcourse) and retest.
Umalo

3

Thursday, October 24th 2013, 4:05pm



I think there is the issue as you defined mp4 for ios, androdid, ..... and if you read documentation:
http://krpano.com/plugins/videoplayer/#html5
you will learn that mp4 is not supported by many HTML5 browsers.

Try with: videourl="video.m4v|video.webm|video.ogv" (prepare all formats ofcourse) and retest.
Umalo</plugin>
Thank you for good words.

Similar threads