You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, November 27th 2013, 12:14am

Error loading video with WebGl+html5 and IE11

Dear Klaus, dear all...
I would like to report this problem ONLY with IE11 and WebGL.
When I upload a video via plugin videoplayer is getting this error:

...Video loading failed!

Link html: http://www.marcostucchi.com/temp/ORIENTATION/CASTIGLIA-Orientation_sph.html
Link xml: http://www.marcostucchi.com/temp/ORIENTA…ntation_sph.xml

I also tested the operation of FireFox, Chrome, Safari and iPad ...with html5=prefer
With Flas mode there is not problems with IE11. Only with WebGl mode.
In these cases, everything works fine. Please see images
Can I resolve this problem...???
Thanks, Marco
mastucc has attached the following images:
  • IE.jpg
  • FireFox.jpg
  • Chrome.jpg

This post has been edited 2 times, last edit by "mastucc" (Nov 30th 2013, 8:28am)


2

Monday, December 9th 2013, 8:59am

Hi,

sorry, but the problem seems to be the video itself - e.g. just try the direct link to the video file in the browsers:

http://www.marcostucchi.com/temp/ORIENTA…o/Castiglia.mp4

Several browsers are not able to decode it (or to decode it correctly) - in my test now only Firefox was able to load and show it correctly.

Maybe try using another video encoder...

Best regards,
Klaus

3

Monday, April 18th 2016, 9:49pm

Hello I was about to write that we had the same problem, but we found out the solution that basically the server gives the wrong MIME type and KRpano cant load the video, hope it helps!