You are not logged in.

Dear visitor, welcome to Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Tuesday, July 14th 2009, 11:07am

Referer header not being sent when requesting XML

It seems that krpano is not sending the referer header when getting the xml from the server.

Doing a quick googling, it seems that "you can send headers using addRequestHeader() when using loadVars or loadXML." It seems to me (not being a flash developer at all), that by default flash is not sending headers when getting external urls.

Is this correct? Is krpano not sending headers when requesting the xml? Can it be forced to do so somehow? Is there somthing I am missing?

Thanks for the help.


Wednesday, July 15th 2009, 1:53pm


right, the Flashplayer doesn't send the referer header,
it and also not possible to add one, see here:…uestHeader.html

a quote from there:


In Flash Player and in Adobe AIR content outside of the application security sandbox, the following request headers cannot be used, and the restricted terms are not case-sensitive (for example, Get, get, and GET are all not allowed). Also, hyphenated terms apply if an underscore character is used (for example, both Content-Length and Content_Length are not allowed):
Accept-Charset, Accept-Encoding, Accept-Ranges, Age, Allow, Allowed, Authorization, Charge-To, Connect, Connection, Content-Length, Content-Location, Content-Range, Cookie, Date, Delete, ETag, Expect, Get, Head, Host, Keep-Alive, Last-Modified, Location, Max-Forwards, Options, Origin, Post, Proxy-Authenticate, Proxy-Authorization, Proxy-Connection, Public, Put, Range, Referer, Request-Range, Retry-After, Server, TE, Trace, Trailer, Transfer-Encoding, Upgrade, URI, User-Agent, Vary, Via, Warning, WWW-Authenticate, x-flash-version.

best regards,


Wednesday, July 15th 2009, 5:42pm

Ok, too bad then, I'll have to find some other way around it.

Thanks for the info.