Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

61

Freitag, 10. Januar 2014, 10:40

Thank you, Klaus, for an update.

New thread about Google maps 1.17 in the plugin maps forum section.
marty

62

Samstag, 11. Januar 2014, 04:02

How to Encrypt the 2048 px images?

Hi,

I've downloaded the newer version and see that there's the ENCRYPT XML droplet.bat which is good as I don't really understand all this command line stuff *confused*

One thing I did like to previously do was encrypt the larger 2048 image tiles but keep the mobile 1024 versions as is for iPad etc. How do I do this now without jumping into
the Command line world? Perhaps make a droplet to just drag them all into?

Many thanks,

Andrew

63

Samstag, 11. Januar 2014, 10:45

One thing I did like to previously do was encrypt the larger 2048 image tiles but keep the mobile 1024 versions as is for iPad etc. How do I do this now without jumping into the Command line world? Perhaps make a droplet to just drag them all into?
Hi,

the ENCRYPT XML encrypts by default only xml and .js plugin files. This was done to avoid the accidentally encryption of any images which might otherwise lead to a wondering or questions why the images aren't working/loading. Encrypted images can be loaded only in Flash, but in the most cases HTML5 will be used by default, and there they will not work.

To allow encrypting images too with the ENCRYPT XML droplet, it would be necessary to open/edit the droplet and to remove the '-h5' setting.

But note - when encrypting the 'desktop' images, you need to care about that for Desktop always the Flash version and never the HTML5 version will be used. This would need to be done in the html file during the viewer embedding with the html5 setting - e.g. detect the 'desktop usage' with custom JS code and set html5=never. Here also keep in mind that you would exclude all desktop systems without installed Flashplayer when doing this.

Best regards,
Klaus

64

Samstag, 11. Januar 2014, 23:16

Hi,

there is a new krpano 1.17 release available:
http://krpano.com/news/#news117pr2

Thanks! By the way, the "license.txt" file still says "(c) 2013".

Also I am wondering why the version number has up to three levels. What kind of change would be needed for a shift of the first digit (krpano 2)?

Regards,
Ash

65

Sonntag, 12. Januar 2014, 01:35

One thing I did like to previously do was encrypt the larger 2048 image tiles but keep the mobile 1024 versions as is for iPad etc. How do I do this now without jumping into the Command line world? Perhaps make a droplet to just drag them all into?
Hi,

the ENCRYPT XML encrypts by default only xml and .js plugin files. This was done to avoid the accidentally encryption of any images which might otherwise lead to a wondering or questions why the images aren't working/loading. Encrypted images can be loaded only in Flash, but in the most cases HTML5 will be used by default, and there they will not work.

To allow encrypting images too with the ENCRYPT XML droplet, it would be necessary to open/edit the droplet and to remove the '-h5' setting.

But note - when encrypting the 'desktop' images, you need to care about that for Desktop always the Flash version and never the HTML5 version will be used. This would need to be done in the html file during the viewer embedding with the html5 setting - e.g. detect the 'desktop usage' with custom JS code and set html5=never. Here also keep in mind that you would exclude all desktop systems without installed Flashplayer when doing this.

Best regards,
Klaus
Thanks for the reply Klaus. Damn I didn't realise that the non flash desktop users wouldn't see the encrypted images. Mind you I did think that everyone with a desktop / laptop would have flash installed and it was just the iPhone, iPad users that didn't have the option to install it but they would see the unencrypted mobile images anyway.

After reading your post I opened up chrome and disabled the flash plugin and sure enough all that was visible was the 'preview' image.

I'm about to create two large tours so will probably lay off the encryption completely as that seems to be the best solution all round.

Thanks again,

Andrew

edfink

Anfänger

Beiträge: 8

Wohnort: Minneapolis, MN USA

Beruf: VR Photographer

  • Nachricht senden

66

Donnerstag, 16. Januar 2014, 17:31

1.117 pr textfield breaks older panos

Don't know whether to post this here or under the textfield plugin. If I swap the new textfield.swf for the older (1.0.8 something) textfield.swf, it breaks ALL my older panos. Just swapping that one file causes the textbox to flash and flicker non-stop, resizing and rearranging the text. If I rebuild the pano with 1.17pr, the new textfield works fine - but I don't have time to rebuild over a thousand panoramas now.

Ed Fink
http://BigEyeInTheSky.com

Tuur

Erleuchteter

Beiträge: 3 017

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

67

Donnerstag, 16. Januar 2014, 17:39

Hi Ed,

When you just change:
- all plugins
- the viewer swf and js

You should be updated i suppose.


Make sure you make a backup of your old plugs and viewer files to be sure.
Use the tour.swf and js that appear when you drop just one pano on the new droplets.

Give it a try
Hope it helps,
Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

edfink

Anfänger

Beiträge: 8

Wohnort: Minneapolis, MN USA

Beruf: VR Photographer

  • Nachricht senden

68

Freitag, 17. Januar 2014, 16:13

Thanks, Tuur!! I can't believe that I never understood that about the viewer! I thought it built a unique .swf for each pano. I guess the only unique thing about it is the name.

Ed Fink
http://BigEyeInTheSky.com

Tuur

Erleuchteter

Beiträge: 3 017

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

69

Freitag, 17. Januar 2014, 16:21

Well it could have been that you made for each pano an swf though..

;-)

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

70

Samstag, 18. Januar 2014, 00:53

A small question about license.

I updated my old pano to 1.17.pr2 and want to use googlemaps.swf because I have my old API for my domain.

Now I get error with license. Until now under 1.16.7 the maps worked well.

I just replaced plugins and krpano.swf and krpano.js with my 1.17.pr2 version.

May I still use old Googlemaps.swf without license error message?

Marty
http://www.virtualczech.cz/bazilikaminor/

71

Montag, 20. Januar 2014, 10:46

I updated my old pano to 1.17.pr2 and want to use googlemaps.swf because I have my old API for my domain.
Hi,

okay, the next release will contain an updated googlemaps.swf with support for the new license system.

But please note - the development of the Google Maps Flash plugin itself has already been discontinued - that means the function set of it will remain at version 1.0.8.15.

Best regards,
Klaus

72

Montag, 20. Januar 2014, 11:09

Thank you Klaus,
yes, I know.
But I have several old API keys for my domains and in some area the Bing maps are very bad.

Thank you

tommo77funk

Fortgeschrittener

Beiträge: 152

Wohnort: London

Beruf: Photographer

  • Nachricht senden

73

Montag, 20. Januar 2014, 14:50

This is excellent ! many thanks Klaus :)

Just a quick questions as blendmode="screen" does not seem to work anymore when used on plugin or layer tag. I checked docs to see if their was an update but none mentioned.

Can anybody check if this param is still working ? It worked for me on 1.16 but on 1.17 is not having desired effect,

thanks and best wishes,

tom

74

Dienstag, 21. Januar 2014, 12:57

Krpano 1.17 demo version not working on iphone 4S (ios 6.0.1)

Hi,
I'm working on gyro concept. I have used krpano 1.16 free demo version and gyro working fine in iPhone 4S. Now i have downloaded krpano 1.17 version and integrated it to work on iphone 4S but app crashes when loading gyro. I'm having iphone 4S (iOS 6.0.1) and used krpano 1.17 free demo version. Why this new version not supporting i phone 4S (iOS 6.0.1)?

75

Dienstag, 21. Januar 2014, 13:06

Hi,
Just a quick questions as blendmode="screen" does not seem to work anymore
Are you sure that you viewing the Flash version? (html5=auto or html5=fallback )

Note - blendmode is a Flash-only setting!
There is no cross-browser equivalent available in HTML5 browsers today.


Zitat

Why this new version not supporting i phone 4S (iOS 6.0.1)?
That should still work of course!
Can you show your example?

Are you using the same images when comparing 1.16 and 1.17?
Normal or Multires?
If Normal - how large are your mobile images - 1024px or larger?

And which krpano version?
krpano 1.17.pr2 or an older one?
Before 1.17.pr2 the hardwarelimit setting, which was automatically reducing too large images, wasn't implemented.

Best regards,
Klaus

76

Dienstag, 21. Januar 2014, 13:18

Hi klaus,

I have used krpano 1.17 version only, not krpano 1.17 pr2. All 6 images of same size 1024*1024. Yes i'm using same image as in krpano 1.16.

77

Dienstag, 21. Januar 2014, 13:21

Hi,

try using 1.17.pr2 and also add this code in the xml:

Quellcode

1
<display hardwarelimit="800" devices="iphone+retina" />


Then the result such be the same as in 1.16.

Best regards,
Klaus

78

Dienstag, 21. Januar 2014, 13:22

Ok.. Let me try and let u know... Thanks a lot.

79

Dienstag, 21. Januar 2014, 14:31

Hi Klaus,

Krpano 1.17.pr2 working fine without adding your code in xml but again krpano 1.17 version not working and showing received memory warning in console then gets crashed. Why its happens only for krpano 1.17 version alone?

tommo77funk

Fortgeschrittener

Beiträge: 152

Wohnort: London

Beruf: Photographer

  • Nachricht senden

80

Mittwoch, 22. Januar 2014, 12:59

Thanks Klaus !

I see html5 is now preferred as default on 1.17 and explains my problem,

thanks and best wishes,

tom