You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

martyhr

Intermediate

  • "martyhr" started this thread

Posts: 350

Location: CZ

  • Send private message

1

Tuesday, January 14th 2014, 5:09pm

video after upgrade to 1.17. NOT WORKING

I just upgraded the tour from 1.16.9 to 1.17 and now I get error in HTML5 mode:

INFO: lat
ERROR: video1918.webm - loading video failed!
ERROR: video1938.webm - loading video failed!
ERROR: video1918.webm - loading video failed!
ERROR: video1938.webm - loading video failed!

i do not know why. All plugins are up-to-date.Version 1.16.9. was OK.

http://www.virtualczech.cz/pamatnikvitkov/indexH5.html

Help pls.

Alexey Tkachenko

Professional

Posts: 760

Location: Sevastopol, Crimea, Russian Federation

Occupation: Interpreting, Building virtual tours

  • Send private message

2

Tuesday, January 14th 2014, 5:54pm

Hi! Try to write the address of the video always as full - to the both sides of the "pipe" character.

Like this:

Source code

1
videourl="videos/video1968.mp4|videos/video1968.webm"


instead of

Source code

1
videourl="videos/video1968.mp4|video1968.webm"
Regards,

Alexey

martyhr

Intermediate

  • "martyhr" started this thread

Posts: 350

Location: CZ

  • Send private message

3

Tuesday, January 14th 2014, 6:25pm

Yes,thanks, better but not enough.

The path helped but if I click, video doesn't play.

In 1.16.9 the uncomplete path was enought and after click the video played.

I have for videoplayer in XML - onclick="togglepause();" and pausedonstart="true" and it worked perfectly in 1.16.9 for Flash and HTML5.

Now I solved ,with your kind help, the path issue but video is not playing after mouse click like before.
I am sad about this troubles after upgrade... *cry*

Alexey Tkachenko

Professional

Posts: 760

Location: Sevastopol, Crimea, Russian Federation

Occupation: Interpreting, Building virtual tours

  • Send private message

4

Tuesday, January 14th 2014, 7:01pm

I've just tested again in Chrome desktop (WebGL) and all videos are played well. What browser and device do you use for test?
Regards,

Alexey

martyhr

Intermediate

  • "martyhr" started this thread

Posts: 350

Location: CZ

  • Send private message

5

Tuesday, January 14th 2014, 8:51pm

Oooohh, I am going crazy.

In FF can not start playing the video and in Chrome I click and video plays.

[url]http://www.virtualczech.cz/pamatnikvitkov/indexH5.html
[/url] *cursing*

IE - yes
FF -NO
Seamonkey -NO
Chrome - yes
Safari - yes *confused*

Alexey Tkachenko

Professional

Posts: 760

Location: Sevastopol, Crimea, Russian Federation

Occupation: Interpreting, Building virtual tours

  • Send private message

6

Tuesday, January 14th 2014, 9:05pm

I see that you use only .mp4 and .webm formats. Convert also to .avi and .flv and add them - to increase cross-browser compatibility.
Regards,

Alexey

martyhr

Intermediate

  • "martyhr" started this thread

Posts: 350

Location: CZ

  • Send private message

7

Tuesday, January 14th 2014, 11:09pm

Well, but I complain only of HTML5 version and of that in 1.16.9 worked it also in FF.

Avi and FLV do not help in HTML5.Or?

8

Sunday, January 19th 2014, 9:56pm

Hi,
I had a similar problem by moving from v1.16.9 to v1.17.: File paths could not be found anymore.

In the html file, which calls the xml-file there is a parameter html5, which can be set to
1. html5:"prefer"
or
2. html5:"auto"
1 means: html5 is used
2 means: flash is used.

In my case the problem only occured, when html5 was set to "prefer", that means under html5.
Try a cross check: I guess, when you set html5 to "auto", it will run as before under flash.

I finally found out, that this problem was a problem of my development enviroment:
I always used Firefox v26 - which does not work. But it works under Safari and MS Windows Explorer.

As soon, when I loaded my panorama (with setting html5:"prefer") on my homepage it worked again, even with Firefox.

The reason may be a safety restriction of Firefox in a local environment.

I hope, this info helps.

Regards

Reggie

Trainee

Posts: 91

Location: Seymour, TN US

Occupation: Virtual Tour Photographer

  • Send private message

9

Tuesday, March 11th 2014, 12:23pm

SOLVED! Thanks Ewald!

I had this same problem and resolved it by changing html5 setting from "prefer" to auto. Thank you, thank you! *w00t* *w00t*

Similar threads