You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

olihar

Trainee

  • "olihar" started this thread

Posts: 140

Location: Iceland

Occupation: Interaction Designer

  • Send private message

1

Monday, January 20th 2014, 9:39pm

limitview="fullrange" on iOS

does limitview="fullrange" not work on iOS?

http://olihar.com/burj-khalifa-from-the-address/

olihar

Trainee

  • "olihar" started this thread

Posts: 140

Location: Iceland

Occupation: Interaction Designer

  • Send private message

2

Friday, January 24th 2014, 4:41pm

or did I miss somwhere that this was not yet supported by iOS.

3

Saturday, January 25th 2014, 8:48am

Hi,

it should work, but it seems there is still a bug related to the fovtype setting (which is VFOV on desktop and MFOV on mobiles/tablets by default).

Here with VFOV:
http://olihar.com/pano/tiles/2013_10_17_…ew.fovtype=VFOV

and here with MFOV:
http://olihar.com/pano/tiles/2013_10_17_…ew.fovtype=MFOV

I will check and fix this of course.

For the meantime just add this setting in the xml as workaround:

Source code

1
<view fovtype="VFOV" />


Best regards,
Klaus

olihar

Trainee

  • "olihar" started this thread

Posts: 140

Location: Iceland

Occupation: Interaction Designer

  • Send private message

4

Thursday, April 3rd 2014, 6:04pm

This bug seems to still be in the final version.

5

Thursday, April 3rd 2014, 6:32pm

Hi,

I have checked this of course and this wasn't a bug, this was the intended behavior.

I don't know the exact details yet (sorry ), but I think there was some kind of dependency between the screen-aspect, the pano-aspect and the fov-type - and for all together the behavior itself was correct (although I agree that the name 'fullrange' suggests that it would show the fullpano regardless of any other things).

But I have extended the default flat-pano skin to be able show the full pano for all cases.
Either use the MAKE PANO (FLAT) droplet for an example or extend your pano with the following code:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
<!-- events and actions for adjusting the view settings to see the whole image -->
<events name="flatpano_events" onnewpano="flatpano_imagefit();" onresize="flatpano_imagefit();" />

<action name="flatpano_imagefit">
    if(image.vfov GT 0,
        div(aspectratio, stagewidth, stageheight);
        if(aspectratio GE 1,
            if(image.vfov GE image.hfov, set(view.fovtype,VFOV), set(view.fovtype,HFOV));
          ,
            if(image.vfov GE image.hfov, set(view.fovtype,HFOV), set(view.fovtype,VFOV));
          );
      );
</action>

With this code, the full pano will be shown, regardless of the screen-size or the pano-size.

Best regards,
Klaus