You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Friday, April 18th 2014, 7:16pm

mwheel:false doesn't allow page scrolling

I have been racking my brain on this one for too long now can someone please tell me why this doesn't work?

Source code

1
<script>  embedpano({swf:"/sites/all/libraries/krpano/krpano.swf", xml:"/node/7/pano.xml", html5:"auto", vars:{mwheel:false}, wmode:"opaque", target:"vtour", width:"908", height:"600"});  </script>



this is how it renders according to safari


Source code

1
<embed name="krpanoSWFObject" id="krpanoSWFObject" width="908" height="600" style="outline:none;" type="application/x-shockwave-flash" src="/sites/all/libraries/krpano/krpano.swf" wmode="opaque" bgcolor="#000000" allowfullscreen="true" allowscriptaccess="always" flashvars="mwheel=false&amp;xml=%2Fnode%2F7%2Fpano.xml">



any help would be greatly appreciated.
Chris

2

Saturday, April 19th 2014, 2:43pm

Hi,

the mwheel setting is a setting for the embedding script and not a krpano viewer variable.

Set it this way (not inside vars):

Source code

1
embedpano({..., mwheel:false, ...});


Best regards,
Klaus