You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Saturday, April 19th 2014, 4:13pm

scrollarea mwheel problem on 1.17

first 1.16.9 code as below:

Source code

1
2
3
4
5
6
7
 <layer name="scrollarea" url="%SWFPATH%/plugins/scrollarea.swf" 
alturl="%SWFPATH%/plugins/scrollarea.js"  align="center" 
 width="350" height="350" direction="all" >
	  
 <layer name="map" align="center" enabled="true" capture="true" 
 scalechildren="True" children="True" 
onhover="set(control.mousefovchange,0);set(events.onmousewheel,if(wheeldelta GT 0,if(layer[map].scale LT 1.1,add(layer[map].scale,0.1)),if(layer[map].scale GT 0.7,sub(layer[map].scale,0.1))));"  onout="set(events.onmousewheel,NULL);set(control.mousefovchange,1);" >



BUT in 1.17 plugins maybe there is scrollarea.mwheel setting, then the child layer[map] can not get the right mousewheel behaviour ,can not get the right scale。

2

Wednesday, April 23rd 2014, 10:14am

Hi,

right, at the moment the mouse wheel events will be always captured by the scrollarea plugin, regardless of the mwheel setting.

I will change that in the next release (1.17.1) - then this will only happen when the mwheel setting is set to true.

Best regards,
Klaus

3

Friday, April 25th 2014, 12:53am

Hi,

right, at the moment the mouse wheel events will be always captured by the scrollarea plugin, regardless of the mwheel setting.

I will change that in the next release (1.17.1) - then this will only happen when the mwheel setting is set to true.

Best regards,
Klaus


Thanks ! Expected update !

Similar threads