You are not logged in.

Dear visitor, welcome to Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Wednesday, May 21st 2014, 1:26pm

Z-order fullscreen Pano viewer

I created a virtual tour with a few panoramas and popup windows with the Fancybox plugin. When I set the tour to fullscreen mode, the browser bar disappears. That's OK.

There is only one problem: The Fancybox popups stays "behind" the virtual tour. The popup window appears when I switch back to a normal browser window. I think there is a Z-order problem. I can set the Z-order for my Fancybox plugin in their CSS. It looks like KR Pano always overrules them and stays always on top of everything....

Does anyone know if there are some options to set the Z-order for KR Pano Fullscreen option?



Posts: 98

Location: Australia

Occupation: Virtual tour creator, VR app developer

  • Send private message


Wednesday, May 21st 2014, 5:07pm

This is unfortunate but expected behaviour with lightbox plugins that use javascript and Flash fullscreen feature.
However it may be ok if you're viewing in HTML5 mode on desktop.Someone else may be able to confirm this??


Thursday, May 22nd 2014, 8:49am

There's is no difference in the HTML5 or Flash version....



Posts: 98

Location: Australia

Occupation: Virtual tour creator, VR app developer

  • Send private message


Thursday, May 22nd 2014, 2:39pm

In that case it seems that Fancybox doesn't support the HTML5 Fullscreen API, at least not out of the box.
This link here leads to a Fancybox version that has support for the API.…en-api-support/

May help solve the HTML5 issue, but with Flash, either way it's no go.
The only way I get around it is to set fullscreen to false when onclick and calling the lightbox.


Source code



Thursday, June 5th 2014, 4:53pm

have the same problem
in fullscreen mode fancybox is disappear

don't like this solution - set(fullscreen,false);
need another solution

may be some params in fancybox script?