You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, June 17th 2014, 11:30am

hotspot size % not correct on samsung S3

Hi !
I'm trying to improve the result of displaying a tour with a lot of hotspots on smartphones and tablets. I decided to use % instead of pixels for spots width.
For example, I tried : width="10%" height="prop"
On desktop computer and Ipad2, the result is fine, but not on samsung galaxy S3, it looks like it displays half size than what it should. Something too small like 5% !
My tour is generated by PTPv2.1.2

in tour_skin.xlm I have now :
<!-- Spot Style - accueil -->
<style name="Iconaccueil"
url="%FIRSTXML%/spots/accueil2_user_defaultpoint4.png"
visible="false"
width="15%" <----- this is displayed 5% instead of 10%
height="prop"
edge="bottom"
ox="0" oy="0"
onhover="onhoverIconaccueil"
onout="onoutIconaccueil" />

The most strange thing is that galaxy S3 displays correctly % width for others elements like buttons
for example, this works fine on S3 :
<layer name="button00"
keep="true"
url="%FIRSTXML%/graphics/button00/lp.png"
align="bottomleft"
x="15%"
y="10"
zorder="23"
visible="false"
onclick="hidebutton20(); hidebutton21(); hidebutton22(); hidebutton23(); hidebutton24(); hidebutton25(); button00OnClick();"
tooltip="button00tooltip"
onhover="showTooltip(bottomleft);"
width="15%" <----- this is displayed 15% correctly
height="prop"
/>

You can see my problem here :
http://www.aircamera.fr/visite_virtuelle/essais_3/360.html
The button on bottom left corner "private lessons" is 15% and the hotspot in the center "ACCUEIL ESF" is 15% also. On samsung S3, the second is twice smaller than the first.

So I don't understand what's going wrong. Does anyone have an idea ?


THANK YOU VERY MUCH IF YOU CAN HELP ME !
Cyril

2

Wednesday, June 18th 2014, 11:05am

Hi,

please try updating to the latest krpano version.

Best regards,
Klaus

3

Thursday, June 19th 2014, 9:50pm

Hello,
Thanks for your answer !
In my xml files, PTPv2.1.2 says Krpano v1.17 but I don't know which one 1.17.x ?

I'm sorry, but I'm not really familiar with Krpano. I'm a Panotour user. So I don't know how I can upgrade to the latest version.
Can you explain me ?Thank you Klaus for your understanding and your patience *smile*
Best !
Cyril

4

Friday, June 20th 2014, 7:06pm

Hi,

try to use the Update Tool from the 'krpano Tools' application.
Drop all swf and js files into it and press update.

Best regards,
Klaus

5

Saturday, June 28th 2014, 9:00am

Hi Klaus !

I tried to upgrade to the last version, and it works now !

Thank you very much !

Cyril