You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, June 30th 2014, 11:09am

Intro Image nur beim Start anzeigen

Hallo,
habe ein Intro image mit basic Infos für die virtuelle Tour eingebaut und möchte das Intro Image aber nur einmal beim start der Tour sehen und nicht jedesmal wenn ich auf das AusgangsPano der Tour klicke.
Habe dazu auch einen alten Beitrag von 2010 gefunden, funktioniert aber nicht.

Hat jemand eine Idee, wie ich das Problem lösen kann.
Danke
beste Grüße
Mr. Cupix

2

Monday, June 30th 2014, 11:47am

So geht es:

Source code

1
2
3
   <action name="startup">set(gBlendZeit,2.0);loadscene("scene_01",null,MERGE);wait(load); <!-- erst das Pano laden --><!-- hier koennte man eine weitere Pause einfuegen. Z.B. wait(2); -->showIntroimage();delayedcall(10, hideIntroimage());</action>
<action name="hideIntroimage">tween(plugin[introimage].alpha, 0.0, get(gBlendZeit), default);wait(get(gBlendZeit)); <!-- das Ausblenden abwarten -->set(plugin[introimage].visible,false); <!-- das durchsichtige Bild unsichtbar machen. Sonst faengt es die MouseEvents ab --></action>
<action name="showIntroimage">set(plugin[introImage].alpha,0); <!-- nur zur Sicherheit. Alpha sollte von hideIntroimage bereits auf 0 gesetzt worden sein. -->set(plugin[introimage].visible,true); <!-- das durchsichtige Bild sichtbar machen. Es ist danach vorhanden, aber immer noch durchsichtig -->tween(plugin[introimage].alpha, 1.0, get(gBlendZeit), default); <!-- einblenden. Die Dauer wurde in startup mit gBlendZeit definiert --></action>    	<scene name="scene_01" title="01" onstart="" thumburl="panos/01.tiles/thumb.jpg" lat="53.950201" lng="10.618051" heading="">       <plugin name="introimage" url="titel4.png" align="center" alpha="0.0" visible="false" zorder="2" onclick="hideintroimage();" />



Beispiel:

http://vepri.de/Virtuelle_Touren/Atelier…vtour/tour.html


Grüße

Harald

3

Monday, June 30th 2014, 1:41pm

hallo,erstmals danke für deine Antwort, doch irgendwie haut das noch nicht hin. Das intro image bleibt unsichtbar und ich komm nicht drauf wo der Fehler liegt. habe den Code an mein introimage angepasst, der code der ersten scene mit dem intro image:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
<scene name="scene_timpano01" title="Aussenbereich" onstart="activatespot(spot1,35);" thumburl="panos/timpano01.tiles/thumb.jpg" >			 <action name="startup">set(gBlendZeit,2.0);loadscene("scene_01",null,MERGE);wait(load); <!-- erst das Pano laden --><!-- hier koennte man eine weitere Pause einfuegen. Z.B. wait(2); -->showIntroimage();delayedcall(10, hideIntroimage());</action><action name="hideIntroimage">tween(plugin[introimage].alpha, 0.0, get(gBlendZeit), default);wait(get(gBlendZeit)); <!-- das Ausblenden abwarten -->set(plugin[introimage].visible,false); <!-- das durchsichtige Bild unsichtbar machen. Sonst faengt es die MouseEvents ab --></action><action name="showIntroimage">set(plugin[introImage].alpha,0); <!-- nur zur Sicherheit. Alpha sollte von hideIntroimage bereits auf 0 gesetzt worden sein. -->set(plugin[introimage].visible,true); <!-- das durchsichtige Bild sichtbar machen. Es ist danach vorhanden, aber immer noch durchsichtig -->tween(plugin[introimage].alpha, 1.0, get(gBlendZeit), default); <!-- einblenden. Die Dauer wurde in startup mit gBlendZeit definiert --></action>    	

 <plugin name="introimage" url="img/steuerung.png" align="center" alpha="0.0" visible="false" zorder="2" onclick="hideintroimage();" />






		<autorotate enabled="false" />
		<view hlookat="-106.042" vlookat="2.806" fovtype="MFOV" fov="120.000" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto" />
		<preview url="panos/timpano01.tiles/preview.jpg" />
		<image>			<cube url="panos/timpano01.tiles/pano_%s.jpg" />			<mobile>				<cube url="panos/timpano01.tiles/mobile_%s.jpg" />			</mobile>		</image>
		<!-- place your scene hotspots here -->		<hotspot name="spot1" style="skin_hotspotstyle|tooltip" ath="-70.600" atv="-2.181" linkedscene="scene_timpano02" />
	</scene>


















wo ist der Fehler, hast du eine Idee?

grüße
cupix

4

Monday, June 30th 2014, 1:51pm

Hi,

pass in der action deinen scene name an. *smile*


Quoted

<action name="startup">set(gBlendZeit,2.0);loadscene("scene_01",null,MERGE);

Quoted

<scene name="scene_timpano01"

Gruß

Harald

5

Monday, June 30th 2014, 2:03pm

hallo,
hab ich gemacht, geht trotzdem aber nicht,:(
g
cupix

6

Monday, June 30th 2014, 2:07pm

Dann probiere mal diesen funktionierenden Code an deine Tour anzupassen:

Source code

1
2
3
4
5
6
7
	<action name="startup">		if(startscene === null, copy(startscene,scene[0].name));		loadscene(get(startscene), null, MERGE);	</action>
		<scene name="scene_01_IMG_9607_Panorama_equi" title="01_Eingang" onstart="">              <!-- Titelbild, das man wegklicken kann, wird nach einigen Sekunden ausgeblendet     -->             <events onloadcomplete="delayedcall(10, hideintroimage() ); set(events.onloadcomplete,null);"></events>                <plugin name="introimage" url="titel-weihnachtsmarkt.png" align="center" visible="true" onloaded="set(alpha,0); tween(alpha,1.0);" zorder="2" onclick="hideintroimage();"></plugin>        <action name="hideintroimage">        if(plugin[introimage].enabled,            set(plugin[introimage].enabled,false);            tween(plugin[introimage].alpha, 0.0, 0.5, default, removeplugin(introimage));            );    </action>  
		<view hlookat="48" vlookat="0" fovtype="MFOV" fov="120" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto"></view>
		<preview url="panos/01_IMG_9607_Panorama_equi.tiles/preview.jpg"></preview>
		<image type="CUBE" multires="true" tilesize="512" progressive="false">			<level tiledimagewidth="3426" tiledimageheight="3426">				<cube url="panos/01_IMG_9607_Panorama_equi.tiles/l3_%s_%v_%h.jpg"></cube>			</level>			<level tiledimagewidth="1713" tiledimageheight="1713">				<cube url="panos/01_IMG_9607_Panorama_equi.tiles/l2_%s_%v_%h.jpg"></cube>			</level>			<level tiledimagewidth="857" tiledimageheight="857">				<cube url="panos/01_IMG_9607_Panorama_equi.tiles/l1_%s_%v_%h.jpg"></cube>			</level>			<mobile>				<cube url="panos/01_IMG_9607_Panorama_equi.tiles/mobile_%s.jpg"></cube>			</mobile>		</image>
		<!-- place your scene hotspots here -->		<hotspot name="spot1" style="skin_hotspotstyle" ath="39.320" atv="23.079" linkedscene="scene_02_img_9586_panorama_equi"></hotspot>		<hotspot name="spot2" style="skin_hotspotstyle" ath="-159.924" atv="8.905" linkedscene="scene_13_img_9814_panorama_equi"></hotspot>
	</scene>

7

Monday, June 30th 2014, 2:32pm

einen schritt weitergekommen, das introimage ladet,
sonst aber alles wie am Anfang, wenn ich den hotspot zum anfangspano klicke, ist das introimage wieder da ...

Source code

1
2
<action name="startup">	if(startscene === null, copy(startscene,scene[0].name));loadscene(get(startscene), null, MERGE);</action>				<scene name="scene_timpano01" title="Aussenbereich" onstart="activatespot(spot1,35);" thumburl="panos/timpano01.tiles/thumb.jpg" >       								     <!-- Titelbild, das man wegklicken kann, wird nach einigen Sekunden ausgeblendet     -->    			         			  <events onloadcomplete="delayedcall(3, hideintroimage() ); set(events.onloadcomplete,null);"></events>   			              			   <plugin name="introimage" url="img/steuerung.png" align="center" visible="true" onloaded="set(alpha,0); tween(alpha,1.0);" zorder="2" onclick="hideintroimage();"></plugin>   			       			    <action name="hideintroimage"> if(plugin[introimage].enabled,set(plugin[introimage].enabled,false);tween(plugin[introimage].alpha, 0.0, 0.5, default, removeplugin(introimage)););</action>  				<view hlookat="-106.042" vlookat="2.806" fovtype="MFOV" fov="120.000" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto" />
		<preview url="panos/timpano01.tiles/preview.jpg" />					<image>			<cube url="panos/timpano01.tiles/pano_%s.jpg" />			<mobile>				<cube url="panos/timpano01.tiles/mobile_%s.jpg" />			</mobile>		</image>-->			



g
cupix

8

Monday, June 30th 2014, 2:59pm

Titel

<krpano version="1.16" title="Alte Kate in Tremsbuettel" onstart="startup();">

<include url="skin/vtourskin.xml" />

<action name="startup">
set(gBlendZeit,2.0);
loadscene("scene_01_Hofseite",null,MERGE);
wait(load); <!-- erst das Pano laden -->
<!-- hier koennte man eine weitere Pause einfuegen. Z.B. wait(2); -->
showIntroimage();
delayedcall(10, hideIntroimage());
</action>

<action name="hideIntroimage">
tween(plugin[introimage].alpha, 0.0, get(gBlendZeit), default);
wait(get(gBlendZeit)); <!-- das Ausblenden abwarten -->
set(plugin[introimage].visible,false); <!-- das durchsichtige Bild unsichtbar machen. Sonst faengt es die MouseEvents ab -->
</action>

<action name="showIntroimage">
set(plugin[introImage].alpha,0); <!-- nur zur Sicherheit. Alpha sollte von hideIntroimage bereits auf 0 gesetzt worden sein. -->
set(plugin[introimage].visible,true); <!-- das durchsichtige Bild sichtbar machen. Es ist danach vorhanden, aber immer noch durchsichtig -->
tween(plugin[introimage].alpha, 1.0, get(gBlendZeit), default); <!-- einblenden. Die Dauer wurde in startup mit gBlendZeit definiert -->
</action>

<scene name="scene_01_Hofseite" title="01_Hofseite" onstart="" thumburl="panos/01_Hofseite.tiles/thumb.jpg" lat="" lng="" heading="">

<view hlookat="0" vlookat="0" fovtype="MFOV" fov="120" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto" />






<plugin name="introimage" url="titel.png" align="center" alpha="0.0" visible="false" zorder="2" onclick="hideintroimage();" />


<preview url="panos/01_Hofseite.tiles/preview.jpg" />

<image type="CUBE" multires="true" tilesize="512" progressive="false">
<level tiledimagewidth="3417" tiledimageheight="3417">
<cube url="panos/01_Hofseite.tiles/l3_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="1709" tiledimageheight="1709">
<cube url="panos/01_Hofseite.tiles/l2_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="855" tiledimageheight="855">
<cube url="panos/01_Hofseite.tiles/l1_%s_%v_%h.jpg" />
</level>
<mobile>
<cube url="panos/01_Hofseite.tiles/mobile_%s.jpg" />
</mobile>
</image>

<!-- place your scene hotspots here -->




<hotspot name="spot1" style="skin_hotspotstyle" ath="-3.091" atv="13.868" linkedscene="scene_02" />

</scene>





<scene name="scene_02_Garten_1" title="02_Garten_1" onstart="" thumburl="panos/02_Garten_1.tiles/thumb.jpg" lat="" lng="" heading="">

<view hlookat="0" vlookat="0" fovtype="MFOV" fov="120" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto" />

<preview url="panos/02_Garten_1.tiles/preview.jpg" />

<image type="CUBE" multires="true" tilesize="512" progressive="false">
<level tiledimagewidth="3383" tiledimageheight="3383">
<cube url="panos/02_Garten_1.tiles/l3_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="1692" tiledimageheight="1692">
<cube url="panos/02_Garten_1.tiles/l2_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="846" tiledimageheight="846">
<cube url="panos/02_Garten_1.tiles/l1_%s_%v_%h.jpg" />
</level>
<mobile>
<cube url="panos/02_Garten_1.tiles/mobile_%s.jpg" />
</mobile>
</image>

<!-- place your scene hotspots here -->

</scene>

<scene name="scene_03_Garten_2" title="03_Garten_2" onstart="" thumburl="panos/03_Garten_2.tiles/thumb.jpg" lat="" lng="" heading="">

<view hlookat="0" vlookat="0" fovtype="MFOV" fov="120" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto" />

<preview url="panos/03_Garten_2.tiles/preview.jpg" />

<image type="CUBE" multires="true" tilesize="512" progressive="false">
<level tiledimagewidth="3410" tiledimageheight="3410">
<cube url="panos/03_Garten_2.tiles/l3_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="1705" tiledimageheight="1705">
<cube url="panos/03_Garten_2.tiles/l2_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="853" tiledimageheight="853">
<cube url="panos/03_Garten_2.tiles/l1_%s_%v_%h.jpg" />
</level>
<mobile>
<cube url="panos/03_Garten_2.tiles/mobile_%s.jpg" />
</mobile>
</image>

<!-- place your scene hotspots here -->
<plugin name="radar1"
url="plugins/radar.swf"
alturl="plugins/radar.js"
parent="bingmap"
align="lefttop"
editmode="false"
x="70" y="80"
keep="false"
scale="1.0"
heading="200"
headingoffset="90.0"
fillcolor="0x3F3F3F"
fillalpha="0.5"
/>
</scene>

<scene name="scene_04_Garten_3" title="04_Garten_3" onstart="" thumburl="panos/04_Garten_3.tiles/thumb.jpg" lat="" lng="" heading="">

<view hlookat="0" vlookat="0" fovtype="MFOV" fov="120" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto" />

<preview url="panos/04_Garten_3.tiles/preview.jpg" />

<image type="CUBE" multires="true" tilesize="512" progressive="false">
<level tiledimagewidth="3429" tiledimageheight="3429">
<cube url="panos/04_Garten_3.tiles/l3_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="1715" tiledimageheight="1715">
<cube url="panos/04_Garten_3.tiles/l2_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="858" tiledimageheight="858">
<cube url="panos/04_Garten_3.tiles/l1_%s_%v_%h.jpg" />
</level>
<mobile>
<cube url="panos/04_Garten_3.tiles/mobile_%s.jpg" />
</mobile>
</image>

<!-- place your scene hotspots here -->

</scene>

<scene name="scene_05_Wiese" title="05_Wiese" onstart="" thumburl="panos/05_Wiese.tiles/thumb.jpg" lat="" lng="" heading="">

<view hlookat="0" vlookat="0" fovtype="MFOV" fov="120" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto" />

<preview url="panos/05_Wiese.tiles/preview.jpg" />

<image type="CUBE" multires="true" tilesize="512" progressive="false">
<level tiledimagewidth="3426" tiledimageheight="3426">
<cube url="panos/05_Wiese.tiles/l3_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="1713" tiledimageheight="1713">
<cube url="panos/05_Wiese.tiles/l2_%s_%v_%h.jpg" />
</level>
<level tiledimagewidth="857" tiledimageheight="857">
<cube url="panos/05_Wiese.tiles/l1_%s_%v_%h.jpg" />
</level>
<mobile>
<cube url="panos/05_Wiese.tiles/mobile_%s.jpg" />
</mobile>
</image>

<!-- place your scene hotspots here -->

</scene>


</krpano>


Alles eben zusammengestellt und getestet. Funktioniert wie gewünscht!

Grüße

Harald

This post has been edited 1 times, last edit by "panox" (Jun 30th 2014, 4:16pm)


9

Tuesday, July 1st 2014, 9:33am

Funktioniert

hallo Harald,
ich habe jetzt die komplette xml Datei mit Hilfe deiner Vorlage neu aufgebaut und jetzt funktioniert es auch !
danke für deine Unterstützung!
beste Grüße
Mr. Cupix

10

Wednesday, July 2nd 2014, 2:32pm

Ich habe ein ähnliches Problem.

ich habe einen Panoramarundgang bei dem es für Desktop eine Map mit Hotspots gibt und für mobile Endgeräte werden die einzelnen Panos über eine Combobox angesteuert.

Jetzt habe ich ebenfalls ein Eingangsbild, welches bei jedem Panoramaaufruf ebenfalls neu geladen wird. Bei der Desktoplösung habe ich das "hideintroimage" über die einzelnen Hotspots gelöst.
Jedoch finde ich für den Aufruf der Panos über die Combobox keine Lösung.

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
<plugin name="combobox" devices="ipad|android|tablet"  url="../plugins/combobox.swf" alturl="../plugins/combobox.js" align="lefttop" x="10" y="10" rowcount="10" width="170" keep="true" onloaded="action(setupitems);"/>

<plugin name="combobox" devices="iphone|ipod"  url="../plugins/combobox.swf" alturl="../plugins/combobox.js" align="lefttop" x="10" y="10" rowcount="10" width="360" keep="true" onloaded="action(setupitems);"/>
	
<action name="setupitems">
		removeall();
        additem(Bitte wählen Sie,);
		additem(Eingangsbereich, action(loadpano,Eingangsbereich);lookat(-10,0,90); );
		additem(Obere Terrasse, action(loadpano,Obere_Terasse);lookat(-66,0,90); );
		additem(Kinderbecken, action(loadpano,Kinderbecken);lookat(50,0,90); );
		additem(Sportbecken, action(loadpano,Sportbecken);lookat(150,0,90); );
		additem(Hallenbad, action(loadpano,Hallenbad);lookat(50,0,90); );
		additem(Saunagarten, action(loadpano,Saunagarten,onclick(hideintroimage));lookat(150,0,90); );
		additem(Sauna EG, action(loadpano,Sauna_oben);lookat(150,0,90); );
		additem(Sauna UG, action(loadpano,Sauna_unten);lookat(150,0,90); );
</action>


Hat hier jemand eine Idee?

Gruss,
Volker

11

Thursday, July 3rd 2014, 11:38am

Hi,

ich bin jetzt nicht ganz sicher wie der ganze Ablauf in dieser Tour aussieht, aber so wie es aussieht gibt es nur in der 1. Scene ein 'Introimage' - von daher - warum dieses nicht nur einmal generell anzeigen (unabhängig ob 1. Scene oder nicht) und dann für immer verstecken.

D.h. das "introimage" außerhalb der <scene> mit keep="true" definieren.

Ansonsten wäre es aber natürlich auch möglich an die Combobox Item onclick Actions noch weitere Befehle (zum Verstecken des Introimages anzuhängen) - z.B. (nur Beispielhafter Code):
additem(Eingangsbereich, action(loadpano,Eingangsbereich);lookat(-10,0,90);verstecke_intro_image(); );

Schöne Grüße,
Klaus

12

Thursday, July 3rd 2014, 11:53am

Ich arbeite nicht mit <scene> sondern habe jedes Pano in einer separaten Xml Datei.

Der Tipp mit

Source code

1
verstecke_intro_image();
an besagter Stelle war aber genial.

Mille Gracie