You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, July 2nd 2014, 10:59am

Strange behavior when image fails to download

We are using krPano version 1.17.4.
We are using cube-strips for preview cube map for the panorama
When one of the 6 panels of the cube map fails to download (for any reason) we observing a black panel in it's place that replaces the low-res preview image.
The desired behavior would be that the low res preview image remains and not replaced with the black texture.
We've seen in some of the examples on the website that this is not the case (this is one such example: http://krpano.com/krpano.html?pano=panos/feldweg/feldweg.xml).
We've tried disconnecting the internet while this example is loading and the low-res preview image was not replaced by the black texture. There doesn't seem to be any difference in our scripts or configuration files...


Any assistance would be very appreciated.

2

Thursday, July 3rd 2014, 11:26am

Hi,

okay, I will check this.

Btw - Flash or HTML5?

Just as note - you could also increase the retrycount setting to let the viewer longer try to load the file:
http://krpano.com/docu/xml/#network.retrycount

Best regards,
Klaus