You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, July 7th 2014, 11:07pm

Panotour, HTML5 und Tooltips...

Hi,

ich ärgere mich grade an einer kleiner Pano-Tour herum und zwar an den Tooltips... Die werden einfach nicht angezeigt... Auch eine Suche hier hat keine Lösung gebracht bzw. die Lösungen haben das Problem nicht gelöst. *cry*

Sollte es nicht bereits in der 1.17 standardmäßig funktionieren wenn man da die enthaltenen Templates nutzt? Ich habe hier die 1.17.4 im Einsatz :(

-->

Quoted


Hi,

das Problem ist folgendes:





  • die vtourskin.xml in diesem Beispiel verwendet 'showtext()' zum Darstellen der Tooltips
  • das Panoramen wird standardmäßig HTML5 (html5=prefer)
  • die showtext() Action wird in HTML5 nicht unterstützt

In den neueren Versionen der vtourskin.xml werden die Tooltips auf eine andere Art, ohne showtext(), realisiert - dort funktionieren diese dann auch in HTML5.

Schöne Grüße,
Klaus




Wie muss ich die Standard vtourskin.xml modifizieren, damit es funktioniert? Oder muss ich die Tooltips an dererer Stelle ergänzen?

Schonmal danke für eine Antwort!

Viele Grüße

Henryk

This post has been edited 3 times, last edit by "henryk86" (Jul 7th 2014, 11:32pm)


2

Tuesday, July 8th 2014, 7:58am

Hi,
Sollte es nicht bereits in der 1.17 standardmäßig funktionieren wenn man da die enthaltenen Templates nutzt?
Ja, allerdings sind diese standardmäßig deaktiviert.
In der tour.xml gibt es aber diese Einstellungen hier um sie bei Bedarf einfach zu aktivieren:

Source code

1
2
3
4
5
6
<skin_settings ...
               tooltips_thumbs="false"
               tooltips_hotspots="false"
               tooltips_mapspots="false"
               ...
               />


Schöne Grüße,
Klaus

3

Tuesday, July 8th 2014, 8:47am

Manchmal bin ich doch blind... ich habe die Einstellungen geändert gehabt und nichts ist passiert... das habe ich allerdings in der skinxml getan... und in der tour.xml hab ich die optionen übersehen... und da da false stand, haben die natürlich das geänderte tru in der skinxml überschrieben... grml...

Danke!